DBMS Connection Wizard: DBMS-Connection-Wizard

DBMS Connection Wizard 1.2.4
  • Hauptseite
  • Zusätzliche Informationen
  • Module
  • Pakete
  • Klassen

DBMS-Connection-Wizard

DBMS-Connection-Wizard | Code-Bibliothek
Erzeugt am Tue Jan 18 2011 22:34:59 für DBMS Connection Wizard von doxygen 1.7.3


DBMS Connection Wizard: Zusätzliche Informationen

  • Module
  • Pakete
  • Klassen

Zusätzliche Informationen

Hier folgt eine Liste mit zusammengehörigen Themengebieten:
  • Ausstehende Aufgaben
  • Liste der bekannten Fehler


DBMS Connection Wizard: Ausstehende Aufgaben

Ausstehende Aufgaben

Namensbereich _initApplication
StartApplication-Prozedur für allgemeine Verwendung umschreiben => in Klasse verlagern

Element ApplicationHandler.GetExtensionInstance (ByVal ExtensionKey As String, Optional ByVal InstanceKey As String=vbNullString) As Object
sollte man eine Schnittstelle statt Late binding verwenden?

Element ApplicationHandler.Version (ByVal appVersion As String)
Versionskennung aus DB-Eigenschaften bzw. aus den Dateieigenschaften lesen

Element modErrorHandler.HandleError (ByVal lErrorNumber As Long, ByVal sSource As String, Optional ByVal sErrDescription As String, Optional ByVal lErrHandlerMode As ACLibErrorHandlerMode=m_conDefaultErrorHandlerMode) As ACLibErrorResumeMode
Prüfung auf Existenz der Datei oder zumindest des Verzeichnisses

Klasse WinApiShortcutMenu
Code aufräumen und Doxygen-Doku erstellen


DBMS Connection Wizard: Liste der bekannten Fehler

Liste der bekannten Fehler

Element ApplicationHandler.MdiBackColor (ByVal Color As Long)
Ermitteln der Hintergrundfarbe des MDI-Bereichs Funktioniert nicht unter Access 2007


DBMS Connection Wizard: Module

Module

Hier folgt die Aufzählung aller Module:
  • DBMS-Connection-Wizard
  • Code-Bibliothek
  • Base


DBMS Connection Wizard: DBMS-Connection-Wizard

DBMS-Connection-Wizard

Access-Add-In: DBMS-Connection-Wizard

Installation

Das Access-Add-In wird über den Add-In-Manger durch hinzufügen der Datei DbmsConnectionWizard.mda installiert. Falls Sie Vista oder Windows 7 verwenden und die Benutzerkontensteuerung (UAC) aktiviert haben, starten Sie zuvor Access als Administrator, da für die Registrierung der Assistenten Admin-Rechte notwendig sind. Sollten es Ihnen nicht möglich sein, Admin-Rechte zu erhalten, so können Sie das Add-In trotzdem verwenden. Es steht Ihnen dann allerdings nur das Menü-Add-In zur Verfügung.

Verbindungsdaten einstellen

Nach der Installation des Access-Add-In steht unter Add-Ins der Eintrag DBMS Connection Wizard zur Verfügung, mit dem der Assistent für die Verbindungskonfiguration gestartet werden kann.

Tabelle erstellen

Falls die Tabelle usys_DbmsConnection im Frontend fehlt, wird diese vom Assistenten erstellt.

Meldung bei fehlender Tabelle

Verbindungskonfiguration erstellen

Mit der Schaltfläche "Neue Verbindung" kann eine neue Verbindungskonfiguration angelegt werden.

Neue Verbindungskonfiguration erstellen

Diese muss einen eindeutigen Namen erhalten und einem DBMS zugeordnet werden.

Eingeben der Verbindungskennung

Zugriffsparameter einstellen

Die Zugriffsparameter werden für jede Verbindungskennung gespeichert.

Verbindungsdaten einstellen

Beschreibung der Parameter

Aufbereitung der Zugriffszeichenfolge

Verbindungsart
  • ohne DSN ("dsn less") Mit dieser Verbindungsart wird eine Zugriffszeichenfolge inkl. Treiber bzw. Provider verwende, die ohne gespeicherte Datenquellen auskommt. Es gibt allerdings einige DBMS, bei denen eine DSN erforderlich ist.
  • mit DSN Die Zugriffszeichenfolge verweist auf eine gespeicherte Datenquelle, in der die Verbindungssparameter enthalten sind.
  • benutzerdefiniert Bei dieser Einstellung wird die Zugriffszeichenfolge nicht aus den Verbindugnsparametern zusammengesetzt sondern exakt jener Zeichenfolge verwendet, die in den Eigenschaften ODBC und OLEDB unter benutzerdefinierter Connectionstring eingetragen werden.

Datenbank- u. Servereinstellungen

Database
Der Datenbankname
Server
Der Server bzw. die Server Instanz. z. B. (local)
Port
Der zu verwendene Port. (Kann meist leer bleiben, wenn der Standardport verwendet wird.
User
Die Benutzerkennung falls eine Serveranmeldung mit Benutzer und Passwort verwendet wird. Bei Verwendung eines Login-Formulars wird im Frontend in diesem Feld der zuletzt angemeldete Benutzer gespeichert.
Password
Das Passwort zur Benutzerkennung
Windows-Autentifizierung
Falls statt einer Serverindentifizierung die Kennung von Windows verwendet werden soll. (Funktioniert nicht mit allen DBMS.)
Login-Formular verwenden
Bei Benutzeranmeldung kann ein Login-formular verwendet werden, um das Passwort abzufragen. (Empfohlene Einstellung, wenn die Windows-Autentifizierung nicht verwendet wird.)
DSN
Die DSN-Kennung, falls eine Verbindung über DSN aufgebaut werden soll

Provider / Driver

OLEDB
Der OLEDB-Provider. Als Standard wird der gängigste Provider zum jeweiligen DBMS voreingestellt. Diese Einstellung kann in der Tabelle usys_DbmsConnection_X geändert werden. Falls ein alternativer Provider verwendet wird, muss möglicherweise die Erstellung der Verbindugnszeichenfolge optimiert werden, falls dieser Provider spezielle Parameter benötigt.
ODBC
Der ODBC-Treiber für den DOBC-Zugriff analog zum OLDEDB-Provider.

Weitere Optionen

OLEDB
Zusätzliche OLEDB-Optionen. Dieser werden am Ende der OLEDB-Verbindungszeichenfolge angehängt.
ODBC
Zusätzliche ODBC-Optionen. Dieser werden am Ende der OLEDB-Verbindungszeichenfolge angehängt.

Benutzerdefinierter Connectionstring

OLEDB
Die OLEDB-Verbindungszeichenfolge bei benutzerdefinierter Konfiguration
ODBC
Die ODBC-Verbindungszeichenfolge bei benutzerdefinierter Konfiguration

Module und Klassen

In diesem Abschnitt könnten die im Frontend benötigten Module aus dem Add-In kopiert werden.


DBMS Connection Wizard: Code-Bibliothek

Code-Bibliothek

Klassen und Module für die Verwendung in den Access-Anwendungen

Beispiele für den Datenzugriff

Beispiele für den Datenzugriff

DAO
 CurrentDbConnection.DAO.OpenRecordset("select ...")

 CurrentDbConnection.DAO.Execute "delete from ..."

 OpenDaoRecordset("select ...")

 DaoExecute "delete from ..."
ADODB
 CurrentDbConnection.ADODB.OpenRecordset("select ...")

 CurrentDbConnection.ADODB.Execute "delete from ..."

 OpenAdoRecordset("select ...")

 AdoExecute "delete from ..."
ODBC
 CurrentDbConnection.ODBC.OpenRecordset(....)

 CurrentDbConnection.ODBC.Execute "delete from ..."

 OpenRecordsetDaoBE("select ...")

 OpenRecordsetPT("select ...")

 OdbcExecutePT "delete from ..."


DBMS Connection Wizard: Base

Klassen | Pakete | Funktionen

Base

Klassen

class | ApplicationHandler
Hauptsteuerung der Anwendung. Mehr ...

Pakete

package | _config_Application

Beispiel für Anwendungskonfiguration.

package | _initApplication

Initialisierungsaufruf der Anwendung.

package | defGlobal

Allgemeine Konstanten und Eigenschaften.

package | modApplication

Standard-Prozeduren für die Arbeit mit ApplicationHandler.

package | modErrorHandler

Prozeduren für die Fehlerbehandlung.

Funktionen

Sub | InitConfig (Optional oCurrentAppHandler As ApplicationHandler=Nothing)
Konfigurationseinstellungen initialisieren.

Dokumentation der Funktionen

Sub _config_Application.InitConfig ( Optional oCurrentAppHandler As ApplicationHandler = Nothing )

Konfigurationseinstellungen initialisieren.

Parameter:
oCurrentAppHandler Möglichkeit einer Referenzübergabe, damit nicht CurrentApplication genutzt werden muss
Rückgabe:


DBMS Connection Wizard: Paket _config_Application

  • Pakete
  • Paketfunktionen
Funktionen

Paket _config_Application
Base

Beispiel für Anwendungskonfiguration. Mehr ...

Funktionen

Sub InitConfig (Optional oCurrentAppHandler As ApplicationHandler=Nothing)
Konfigurationseinstellungen initialisieren.

Ausführliche Beschreibung

Beispiel für Anwendungskonfiguration.

Indiviuell gestaltete Config-Module nicht in das Repositiory laden.


DBMS Connection Wizard: Paket _initApplication

  • Pakete
  • Paketfunktionen
Funktionen

Paket _initApplication
Base

Initialisierungsaufruf der Anwendung. Mehr ...

Funktionen

Function StartApplication (Optional ByRef param As Variant) As Boolean
Prozedur für den Anwendungsstart.

Ausführliche Beschreibung

Initialisierungsaufruf der Anwendung.

Noch zu erledigen:
StartApplication-Prozedur für allgemeine Verwendung umschreiben => in Klasse verlagern

Dokumentation der Funktionen

Function _initApplication.StartApplication ( Optional ByRef param As Variant )

Prozedur für den Anwendungsstart.

Rückgabe:
Boolean


DBMS Connection Wizard: Paket defGlobal

  • Pakete
  • Paketfunktionen
Funktionen

Paket defGlobal
Base

Allgemeine Konstanten und Eigenschaften. Mehr ...

Funktionen

Property Get CurrentApplicationName () As String
Name der aktuellen Anwendung.

Ausführliche Beschreibung

Allgemeine Konstanten und Eigenschaften.

Dokumentation der Funktionen

Property Get defGlobal.CurrentApplicationName ( )

Name der aktuellen Anwendung.

Rückgabe:
String

Verwendet CurrentApplication.ApplicationName


DBMS Connection Wizard: Paket modApplication

  • Pakete
  • Paketfunktionen
Funktionen

Paket modApplication
Base

Standard-Prozeduren für die Arbeit mit ApplicationHandler. Mehr ...

Funktionen

Property Get | CurrentApplication () As ApplicationHandler
Property für ApplicationHandler-Instanz (diese Property im Code verwenden)
Sub | AddApplicationHandlerExtension (ByRef objRef As Object)
Erweiterung zu Collection hinzufügen.
Sub | TraceLog (ByRef Msg As String, ParamArray Args() As Variant)
TraceLog.
Sub | DisposeCurrentApplicationHandler ()
Instanz von ApplicationHandler und den Erweiterungen zerstören.

Ausführliche Beschreibung

Standard-Prozeduren für die Arbeit mit ApplicationHandler.

Dokumentation der Funktionen

Sub modApplication.AddApplicationHandlerExtension ( ByRef objRef As Object )

Erweiterung zu Collection hinzufügen.

Parameter:
objRef Referenz auf Instanz der Erweiterung

Referenz wird in Collection abgelegt, damit keine zusätzliche (manuelle) Referenzspeicherung notwendig ist.

Property Get modApplication.CurrentApplication ( )

Property für ApplicationHandler-Instanz (diese Property im Code verwenden)

Rückgabe:
aktuelle Instanz von ApplicationHandler
Sub modApplication.TraceLog | ( | ByRef Msg As | String,
 |  | ParamArray Args() As | Variant
 | ) |  |

TraceLog.

Parameter:
Param
Rückgabe:


DBMS Connection Wizard: Paket modErrorHandler

  • Pakete
  • Paketfunktionen
Aufzählungen | Funktionen

Paket modErrorHandler
Base

Prozeduren für die Fehlerbehandlung. Mehr ...

Aufzählungen

enum | ACLibErrorHandlerMode

ErrorHandler Modes (Fehlerbehandlungsvarianten)

Mehr ...
enum | ACLibErrorResumeMode

Verarbeitungsparamter bei aufgetretene Fehler.

Mehr ...
enum | ACLibErrorNumbers

ErrorHandler Modes (Fehlerbehandlungsvarianten)

Funktionen

Property Get | DefaultErrorHandlerMode () As ACLibErrorHandlerMode
Standardverhalten der Fehlerbehandlung.
Property Let | DefaultErrorHandlerMode (ByVal errMode As ACLibErrorHandlerMode)
Standardverhalten der Fehlerbehandlung.
Property Get | ErrorHandlerLogFile () As String
Log file für Fehlermeldungen.
Property Let | ErrorHandlerLogFile (ByVal Path As String)
Log file für Fehlermeldungen.
Function | HandleError (ByVal lErrorNumber As Long, ByVal sSource As String, Optional ByVal sErrDescription As String, Optional ByVal lErrHandlerMode As ACLibErrorHandlerMode=m_conDefaultErrorHandlerMode) As ACLibErrorResumeMode
Standard-Prozedur für Fehlerbehandlung.

Ausführliche Beschreibung

Prozeduren für die Fehlerbehandlung.

Dokumentation der Aufzählungstypen

enum ACLibErrorHandlerMode

ErrorHandler Modes (Fehlerbehandlungsvarianten)

aclibErrRaise (0) | Weitergabe an Anwendung
aclibErrMsgBox (1) | Fehler in MsgBox anzeigen
aclibErrIgnore (2) | keine Meldung ausgeben
aclibErrFile (4) | Fehlerinformation in Datei schreiben

Die Werte {0,1,2} schließen sich gegenseitig aus. Der Werte 4 (aclibErrFile) kann beliebig zu {0,1,2} addiert werden. Beispiel: Init aclibErrRaise + aclibErrFile

enum ACLibErrorResumeMode

Verarbeitungsparamter bei aufgetretene Fehler.

aclibErrExit (0) | Abbruch (Funktionsaustritt)
aclibErrResume (1) | Resume, Problem von außen behoben
aclibErrResumeNext (2) | Resume next, im Code an nächster Stelle weiterarbeiten

Wird bei Error-Events genutzt

Dokumentation der Funktionen

Property Let modErrorHandler.DefaultErrorHandlerMode ( ByVal errMode As ACLibErrorHandlerMode )

Standardverhalten der Fehlerbehandlung.

Parameter:
errMode ACLibErrorHandlerMode
Property Let modErrorHandler.ErrorHandlerLogFile ( ByVal Path As String )

Log file für Fehlermeldungen.

Parameter:
errMode ACLibErrorHandlerMode
Function modErrorHandler.HandleError | ( | ByVal lErrorNumber As | Long,
 |  | ByVal sSource As | String,
 |  | Optional ByVal sErrDescription As | String,
 |  | Optional ByVal lErrHandlerMode As | ACLibErrorHandlerMode = m_conDefaultErrorHandlerMode
 | ) |  |

Standard-Prozedur für Fehlerbehandlung.

Noch zu erledigen:
Prüfung auf Existenz der Datei oder zumindest des Verzeichnisses
Parameter:
lErrorNumber
sSource
sErrDescription
lErrHandlerMode
Rückgabe:
ACLibErrorResumeMode

Beispiel: == Private Sub Beispiel()

On Error GoTo HandleErr

[...]

ExitHere: On Error Resume Next Exit Sub

HandleErr: Select Case HandleError(Err.Number, "Beispiel", Err.Description) Case ACLibErrorResumeMode.aclibErrResume Resume Case ACLibErrorResumeMode.aclibErrResumeNext Resume Next Case Else Resume ExitHere End Select

End Sub ==


DBMS Connection Wizard: ApplicationHandler Klassenreferenz

  • Auflistung der Klassen
  • Klassen-Verzeichnis
  • Klassen-Elemente
Öffentliche Methoden | Freundbeziehungen

ApplicationHandler Klassenreferenz
Base

Hauptsteuerung der Anwendung. Mehr ...

Aufstellung aller Elemente

Öffentliche Methoden

Function | Start (Optional ByRef ResumeMessage As Variant) As Boolean
Start der Anwendung.
Property Get | ApplicationName () As String
Name der aktuellen Anwendung.
Property Let | ApplicationName (ByVal AppName As String)
Name der aktuellen Anwendung einstellen.
Property Get | ApplicationFullName () As String
Vollständiger Name der aktuellen Anwendung.
Property Let | ApplicationFullName (ByVal AppName As String)
Name der aktuellen Anwendung einstellen.
Property Get | Version () As String
Vollständiger Name der aktuellen Anwendung.
Property Let | Version (ByVal appVersion As String)
Name der aktuellen Anwendung einstellen.
Property Get | ApplicationStartFormName () As String
Formular, das in der Methode Start geöffnet wird.
Property Let | ApplicationStartFormName (ByVal FormName As String)
Formular, das in der Methode Start geöffnet wird.
Property Get | AppDb () As DAO.Database
Ersatz für CurrentDb bzw. CodeDb (Standard: CodeDb)
Function | CreateAppFile (ByVal sFileID As String, ByVal sFileName As String) As Boolean
Datei aus AppFile-Tabelle extrahieren.
Function | GetExtensionInstance (ByVal ExtensionKey As String, Optional ByVal InstanceKey As String=vbNullString) As Object
Sub | CallExtensionProcedure (ByVal Key As String, ByVal ProcedureName As String, ByRef ResumeMode As ApplicationHandlerResumeModes, ByRef ResumeMessage As Variant, ByRef params() As Variant)
Prozeduren aus Erweiterungen aufrufen.

Freundbeziehungen

Property Let | MdiBackColor (ByVal Color As Long)

Ausführliche Beschreibung

Hauptsteuerung der Anwendung.

Dokumentation der Elementfunktionen

Property Get AppDb ( )

Ersatz für CurrentDb bzw. CodeDb (Standard: CodeDb)

Rückgabe:
zugewiesene DAO.Database-Instanz
Property Get ApplicationFullName ( )

Vollständiger Name der aktuellen Anwendung.

Rückgabe:
String

Reihenfolge der Namensermittlung: 1. über gesetzten Wert 2. über ApplicationName

Property Let ApplicationFullName ( ByVal AppName As String )

Name der aktuellen Anwendung einstellen.

Parameter:
appName Anwendungsname
Property Get ApplicationName ( )

Name der aktuellen Anwendung.

Rückgabe:
String

Reihenfolge der Namensermittlung: 1. über gesetzten Wert 2. aus Titel-Eigenschaft mit CurrentDb.Properties("AppTitle") 3. aus Dateinamen mit CurrentDb.Name

Property Let ApplicationName ( ByVal AppName As String )

Name der aktuellen Anwendung einstellen.

Parameter:
appName Anwendungsname
Sub CallExtensionProcedure | ( | ByVal Key As | String,
 |  | ByVal ProcedureName As | String,
 |  | ByRef ResumeMode As | ApplicationHandlerResumeModes,
 |  | ByRef ResumeMessage As | Variant,
 |  | ByRef params() As | Variant
 | ) |  |

Prozeduren aus Erweiterungen aufrufen.

Parameter:
Key | Extension-Kennung
ProcedureName | Name der zu startenden Prozedur
ResumeMode | Rückgabekennung
ResumeMessage | Antwort
Params | Array für Übergabe- und Rückgabeparameter
Rückgabe:
Function CreateAppFile | ( | ByVal sFileID As | String,
 |  | ByVal sFileName As | String
 | ) |  |

Datei aus AppFile-Tabelle extrahieren.

Parameter:
sFileID Kennung in Tabelle
sFileName
Rückgabe:
True = Datei wurde gespeichert

Erfordert AppFile-Erweiterung (wird über Ereignis-Schnittstelle angesprochen)

Function GetExtensionInstance | ( | ByVal ExtensionKey As | String,
 |  | Optional ByVal InstanceKey As | String = vbNullString
 | ) |  |
Noch zu erledigen:
sollte man eine Schnittstelle statt Late binding verwenden?
Function Start ( Optional ByRef ResumeMessage As Variant )

Start der Anwendung.

Rückgabe:
Boolean

Nicht Verwechseln mit Initialisierung von ApplicationHandler
Diese Prozedur löst die Startroutine für den Anwender aus.

Property Let Version ( ByVal appVersion As String )

Name der aktuellen Anwendung einstellen.

Noch zu erledigen:
Versionskennung aus DB-Eigenschaften bzw. aus den Dateieigenschaften lesen
Parameter:
appName Anwendungsname
Property Get Version ( )

Vollständiger Name der aktuellen Anwendung.

Rückgabe:
String

Reihenfolge der Namensermittlung: 1. über gesetzten Wert 2. über ApplicationName

Freundbeziehungen und Funktionsdokumentation

Property Let MdiBackColor ( ByVal Color As Long ) [friend]
Fehler:
Ermitteln der Hintergrundfarbe des MDI-Bereichs Funktioniert nicht unter Access 2007
Die Dokumentation für diese Klasse wurde erzeugt aufgrund der Datei:
  • ApplicationHandler.cls


DBMS Connection Wizard: Auflistung der Klassen

  • Auflistung der Klassen
  • Klassen-Verzeichnis
  • Klassen-Elemente

Auflistung der Klassen

Hier folgt die Aufzählung aller Klassen, Strukturen, Varianten und Schnittstellen mit einer Kurzbeschreibung:
AdodbHandler | ADODB-Zugriffsmethoden
ApplicationHandler | Hauptsteuerung der Anwendung
DaoHandler | DAO-Zugriffsmethoden
DbConnectionHandler | Datenbankverbindung per ADO oder DAO (inkl. ODBC)
DbConnectionInfo | Hilfsklasse zur Einstellung der Verbingungsparameter
DbConnectionManager | Klasse zur Instanzierung, Terminierung und Basissteuerung von Hilfsklassen
DbmsConnectionStrings | Type für die gleichzeitige Übergabe der Connectionsstrings
Form_frmConfig_DBMS | Form_frmConfig_DBMS
OdbcHandler | ODBC-Zugriffsmethoden
WinApiShortcutMenu | ShortcutMenu über Win-API


DBMS Connection Wizard: AdodbHandler Klassenreferenz

  • Auflistung der Klassen
  • Klassen-Verzeichnis
  • Klassen-Elemente
Öffentliche Methoden

AdodbHandler Klassenreferenz

ADODB-Zugriffsmethoden. Mehr ...

Aufstellung aller Elemente

Öffentliche Methoden

Event | ErrorMissingCurrentConnection (ByVal Msg As String, ByRef NewCurrentConnection As ADODB.Connection)
Ereignis für fehlende ADODB-Connection-Referenz.
Event | ErrorEmptyConnectionString (ByVal Msg As String, ByRef NewConnectionString As String)
Ereignis für fehlenden OLEDB-Connectionstring.
Property Get | CurrentConnection () As ADODB.Connection
Aktuell eingestellte ADODB-Connction.
Property Set | CurrentConnection (ByRef NewConnection As ADODB.Connection)
Übergabe einer ADODB-Connection.
Property Get | ConnectionString () As String
OLEDB-Connectionstring.
Property Let | ConnectionString (ByVal Value As String)
OLEDB-Connectionstring.
Function | Execute (ByVal CommandText As String, Optional ByRef RecordsAffected As Long, Optional ByVal Options As ADODB.ExecuteOptionEnum=-1) As ADODB.Recordset
Sql-Anweisung ausführen.
Function | ExecuteCommand (ByVal CmdText As String, ByVal CmdType As ADODB.CommandTypeEnum, Optional ByVal CmdParamDefs As Variant, Optional ByRef RecordsAffected As Long, Optional ByVal Options As Long=-1) As ADODB.Recordset
Sql-Anweisung mittels ADODB.Command ausführen.
Function | OpenRecordset (ByVal Source As String, Optional ByVal CursorType As ADODB.CursorTypeEnum=ADODB.CursorTypeEnum.adOpenForwardOnly, Optional ByVal LockType As ADODB.LockTypeEnum=ADODB.LockTypeEnum.adLockReadOnly, Optional ByVal CursorLocation As ADODB.CursorLocationEnum=ADODB.CursorLocationEnum.adUseServer, Optional ByVal DisconnectedRecordset As Boolean=False) As ADODB.Recordset
OpenRecordset.
Function | LookupSQL (ByVal SqlText As String, Optional ByVal Index As Variant=0 &, Optional ByVal ValueIfNull As Variant=Null) As Variant
Lookup-Recordset-Ersatzfunktion für Übergabe einer vollständigen SQL-Anweisung.
Function | Lookup (ByVal Expr As String, ByVal Domain As String, Optional ByVal Criteria As Variant, Optional ByVal ValueIfNull As Variant=Null) As Variant
Lookup-Recordset-Ersatzfunktion.
Function | Count (ByVal Expr As String, ByVal Domain As String, Optional ByVal Criteria As Variant) As Long
DCount-Recordset-Ersatzfunktion.
Function | Max (ByVal Expr As String, ByVal Domain As String, Optional ByVal Criteria As Variant) As Variant
DMax-Recordset-Ersatzfunktion.
Function | Min (ByVal Expr As String, ByVal Domain As String, Optional ByVal Criteria As Variant) As Variant
DMin-Recordset-Ersatzfunktion.
Function | Sum (ByVal Expr As String, ByVal Domain As String, Optional ByVal Criteria As Variant) As Variant
DSum-Recordset-Ersatzfunktion.
Function | InsertIdentityReturn (ByVal InsertSQL As String, Optional ByVal IdentityTable As String=vbNullString) As Variant
Insert-SQL-Anweisung ausführen und letzten Identity-Wert (Autowert) zurückgeben.

Ausführliche Beschreibung

ADODB-Zugriffsmethoden.

Autor:
Josef Poetzl

Dokumentation der Elementfunktionen

Property Get ConnectionString ( )

OLEDB-Connectionstring.

Rückgabe:
OLEDB-Connectionstring
Property Let ConnectionString ( ByVal Value As String )

OLEDB-Connectionstring.

Parameter:
Value OLEDB-Connectionstring für den Verbindungaufbau
Function Count | ( | ByVal Expr As | String,
 |  | ByVal Domain As | String,
 |  | Optional ByVal Criteria As | Variant
 | ) |  |

DCount-Recordset-Ersatzfunktion.

Parameter:
Expr | Feldname oder berechneter Ausdruck (Select-Teil)
Domain | Tabelle, Abfrage oder SQL-Ausdruck für Sub-Abfrage (FROM-Teil)
Criteria | Filter (WHERE-Teil)
Rückgabe:
Long
Property Set CurrentConnection ( ByRef NewConnection As ADODB. Connection )

Übergabe einer ADODB-Connection.

Parameter:
NewConnection Neue ADODB-Connection
Property Get CurrentConnection ( )

Aktuell eingestellte ADODB-Connction.

Rückgabe:
ADODB.Connection

Falls noch keine ADODB-Connection vorhanden ist, wird eine neue ADODB-Verbindung erstellt. Ablauf der Instanzieren: 1. RaiseEvent ErrorMissingCurrentConnection ... falls keine Connection übergeben wurde: 2. Neue ADODB-Connection auf Basis des OLEDB-Connectionstring erzeugen (Einsatz der Eigenschaft ConnectionString)

Falls bereits eine Referenz zu einer ADODB-Connection vorhanden ist, wird geprüft, ob diese geschlossen ist und im Bedarfsfall geöffnet.

Event ErrorEmptyConnectionString | ( | ByVal Msg As | String,
 |  | ByRef NewConnectionString As | String
 | ) |  |

Ereignis für fehlenden OLEDB-Connectionstring.

Parameter:
Msg | Meldung über Ursache der Ereignisauslösung. (Wird noch nicht genutzt)
NewConnectionString | OLEDB-Connectionstring

über den ByRef-Parameter NewConnectionString kann der passende OLEDB-Connectionstring weitergegeben werden.

Event ErrorMissingCurrentConnection | ( | ByVal Msg As | String,
 |  | ByRef NewCurrentConnection As ADODB. | Connection
 | ) |  |

Ereignis für fehlende ADODB-Connection-Referenz.

Parameter:
Msg | Meldung über Ursache der Ereignisauslösung. (Wird noch nicht genutzt)
NewCurrentConnection | ADODB.Connection-Referenz, die für CurrentConnection verwendet werden soll

Über den ByRef-Parameter NewCurrentConnection kann die passende ADODB.Database-Referenz weitergegeben werden. Eine Referenz-Weitergabe ist allerdings nicht zwingend erforderlich, da z. B. in der Methode CurrentConnection die Connection dann aus dem ConnectionString erstellt wird.

Function Execute | ( | ByVal CommandText As | String,
 |  | Optional ByRef RecordsAffected As | Long,
 |  | Optional ByVal Options As ADODB. | ExecuteOptionEnum = -1
 | ) |  |

Sql-Anweisung ausführen.

Parameter:
CommandText | SQL-Anweisung
RecordsAffected | ByRef-Parameter zur Rückgabe der Anzahl der von der Execute-Anweisung betroffenen Datensätze
Options | zusätztliche Optionen der ADODB.Connection-Execute-Methode
Rückgabe:
ADODB.Recordset

Kapselung der ADODB.Connection.Execute-Methode (Parameter werden 1:1 weitergereicht)

Function ExecuteCommand | ( | ByVal CmdText As | String,
 |  | ByVal CmdType As ADODB. | CommandTypeEnum,
 |  | Optional ByVal CmdParamDefs As | Variant,
 |  | Optional ByRef RecordsAffected As | Long,
 |  | Optional ByVal Options As | Long = -1
 | ) |  |

Sql-Anweisung mittels ADODB.Command ausführen.

Parameter:
CmdText | ADODB.CommandText-Wert
CmdType | ADODB.CommandType-Wert
commandParamDefs | 2-dimensionales Parameter-Array (Array(n,1) ... x(n,0) = Parametername, x(n,1) = Parameterwert)
RecordsAffected | ByRef-Parameter zur Rückgabe der Anzahl der von der Execute-Anweisung betroffenen Datensätze
Options | zusätztliche Optionen der ADODB.Connection-Execute-Methode
Rückgabe:
ADODB.Recordset

Mit dieser Variante kann sehr einfach SQL-Injection vermieden werden, da die Parameter nicht direkt in der SQL-Anweisung eingebaut sind und somit ein Parameterwert (der z. B. von einer Benutzereingabe stammt) keine SQL-Anweisung einschleusen kann.

Function InsertIdentityReturn | ( | ByVal InsertSQL As | String,
 |  | Optional ByVal IdentityTable As | String = vbNullString
 | ) |  |

Insert-SQL-Anweisung ausführen und letzten Identity-Wert (Autowert) zurückgeben.

Parameter:
InsertSQL Insert-SQL-Anweisung (INSERT ...)
Rückgabe:
Identity-Wert oder NULL falls kein Datensatz angefügt wurde

Funktioniert für Jet erst ab Jet 4.0 (Access 2000), IdentityTable ist nur für MSSQL anwendbar, unter MySQL gibt es die Funktion IDENT_CURRENT nicht.

Function Lookup | ( | ByVal Expr As | String,
 |  | ByVal Domain As | String,
 |  | Optional ByVal Criteria As | Variant,
 |  | Optional ByVal ValueIfNull As | Variant = Null
 | ) |  |

Lookup-Recordset-Ersatzfunktion.

Parameter:
Expr | Feldname oder berechneter Ausdruck (Select-Teil)
Domain | Tabelle, Abfrage oder SQL-Ausdruck für Sub-Abfrage (FROM-Teil)
Criteria | Filter (WHERE-Teil)
Rückgabe:
Variant
Function LookupSQL | ( | ByVal SqlText As | String,
 |  | Optional ByVal Index As | Variant = 0 &,
 |  | Optional ByVal ValueIfNull As | Variant = Null
 | ) |  |

Lookup-Recordset-Ersatzfunktion für Übergabe einer vollständigen SQL-Anweisung.

Parameter:
SqlText | SQL-Anweisung
Index | Feldauswahl, falls nicht das erste Feld des Recordsets zurückgeliefert werden soll. Die Index-Übergabe erfolgt analaog ADODB.Recordset.Fields(index)
ValueIfNull | Rückgabewert bei fehlendem Datensatz oder NULL-Feldwert (Standard: Null
Rückgabe:
Variant (NULL, falls SQL-Anweisung keinen Datensatz liefert.)

Die SQL-Anweisung ist im SQL-Dialekt des betroffenen DBMS zu schreiben.

Function Max | ( | ByVal Expr As | String,
 |  | ByVal Domain As | String,
 |  | Optional ByVal Criteria As | Variant
 | ) |  |

DMax-Recordset-Ersatzfunktion.

Parameter:
Expr | Feldname oder berechneter Ausdruck (Select-Teil)
Domain | Tabelle, Abfrage oder SQL-Ausdruck für Sub-Abfrage (FROM-Teil)
Criteria | Filter (WHERE-Teil)
Rückgabe:
Variant
Function Min | ( | ByVal Expr As | String,
 |  | ByVal Domain As | String,
 |  | Optional ByVal Criteria As | Variant
 | ) |  |

DMin-Recordset-Ersatzfunktion.

Parameter:
Expr | Feldname oder berechneter Ausdruck (Select-Teil)
Domain | Tabelle, Abfrage oder SQL-Ausdruck für Sub-Abfrage (FROM-Teil)
Criteria | Filter (WHERE-Teil)
Rückgabe:
Variant
Function OpenRecordset | ( | ByVal Source As | String,
 |  | Optional ByVal CursorType As ADODB. | CursorTypeEnum = ADODB.CursorTypeEnum.adOpenForwardOnly,
 |  | Optional ByVal LockType As ADODB. | LockTypeEnum = ADODB.LockTypeEnum.adLockReadOnly,
 |  | Optional ByVal CursorLocation As ADODB. | CursorLocationEnum = ADODB.CursorLocationEnum.adUseServer,
 |  | Optional ByVal DisconnectedRecordset As | Boolean = False
 | ) |  |

OpenRecordset.

Parameter:
Source | Datenquelle (z.B. SQL-Anweisung)
CursorType | ADODB.CursorTypeEnum-Wert
LockType | ADODB.LockTypeEnum-Wert
CursorLocation | ADODB.CursorLocationEnum-Wert
DisconnectedRecordset | True: Verbindung nach Öffnen des Recordset kappen ... verbindungsloses Recordset
Rückgabe:
ADODB.Recordset
Function Sum | ( | ByVal Expr As | String,
 |  | ByVal Domain As | String,
 |  | Optional ByVal Criteria As | Variant
 | ) |  |

DSum-Recordset-Ersatzfunktion.

Parameter:
Expr | Feldname oder berechneter Ausdruck (Select-Teil)
Domain | Tabelle, Abfrage oder SQL-Ausdruck für Sub-Abfrage (FROM-Teil)
Criteria | Filter (WHERE-Teil)
Rückgabe:
Variant
Die Dokumentation für diese Klasse wurde erzeugt aufgrund der Datei:
  • AdodbHandler.cls


DBMS Connection Wizard: DaoHandler Klassenreferenz

  • Auflistung der Klassen
  • Klassen-Verzeichnis
  • Klassen-Elemente
Öffentliche Methoden

DaoHandler Klassenreferenz

DAO-Zugriffsmethoden. Mehr ...

Aufstellung aller Elemente

Öffentliche Methoden

Event | ErrorMissingCurrentDb (ByVal Msg As String, ByRef NewCurrentDbRef As DAO.Database)
Ereignis für fehlende CurrentDb-Referenz.
Property Get | CurrentDb () As DAO.Database
CurrentDbC-Variante.
Property Set | CurrentDb (ByRef NewCurrentDb As DAO.Database)
Übergabe der DAO-Database-Referenz.
Function | Execute (ByVal Query As String, Optional ByVal Options As DAO.RecordsetOptionEnum) As Long
SQL-Anweisung ausführen.
Function | ExecuteParamSQL (ByVal SqlText As String, ParamArray ParamValues() As Variant) As Long
Sql-Anweisung mit Parametern ausführen.
Function | ExecuteQueryDefByName (ByVal QueryName As String, Optional ByVal QueryParamDefs As Variant) As Long
Gespeicherte Abfrage (optional mit Parametern) ausführen.
Function | ExecuteQueryDef (ByVal qdf As DAO.QueryDef, Optional ByVal QdfParamDefs As Variant) As Long
Gespeicherte Abfrage (optional mit Parametern) ausführen.
Function | OpenRecordset (ByVal Source As String, Optional ByVal RecordsetType As DAO.RecordsetTypeEnum=dbOpenDynaset, Optional ByVal RecordsetOptions As DAO.RecordsetOptionEnum=DAO.RecordsetOptionEnum.dbSeeChanges, Optional ByVal LockEdit As DAO.LockTypeEnum=DAO.LockTypeEnum.dbOptimistic) As DAO.Recordset
Recordset öffnen.
Function | OpenRecordsetParamSQL (ByVal ParamSqlText As String, ByVal RecordsetType As DAO.RecordsetTypeEnum, ByVal Options As DAO.RecordsetOptionEnum, ByVal LockEdit As DAO.LockTypeEnum, ParamArray ParamValues() As Variant) As DAO.Recordset
Parameter-SQL-Anweisung öffnen (verwendet temporäres QueryDef)
Function | OpenRecordsetQueryDefByName (ByVal QueryName As String, Optional ByVal QueryParamDefs As Variant, Optional ByVal RecordsetType As DAO.RecordsetTypeEnum, Optional ByVal Options As DAO.RecordsetOptionEnum, Optional ByVal LockEdit As DAO.LockTypeEnum) As DAO.Recordset
Recordset von gespeicherter Abfrage (optional mit Parametern) öffnen.
Function | OpenRecordsetQueryDef (ByVal qdf As DAO.QueryDef, Optional ByVal QdfParamDefs As Variant, Optional ByVal RecordsetType As DAO.RecordsetTypeEnum, Optional ByVal Options As DAO.RecordsetOptionEnum, Optional ByVal LockEdit As DAO.LockTypeEnum) As DAO.Recordset
Recordset von gespeicherter Abfrage (optional mit Parametern) öffnen.
Function | LookupSQL (ByVal SqlText As String, Optional ByVal Index As Variant=0 &, Optional ByVal ValueIfNull As Variant=Null) As Variant
Lookup-Recordset-Ersatzfunktion für die Übergabe einer vollständigen SQL-Anweisung.
Function | Lookup (ByVal Expr As String, ByVal Domain As String, Optional ByVal Criteria As Variant, Optional ByVal ValueIfNull As Variant=Null) As Variant
Lookup-Recordset-Ersatzfunktion.
Function | Count (ByVal Expr As String, ByVal Domain As String, Optional ByVal Criteria As Variant) As Long
DCount-Recordset-Ersatzfunktion.
Function | Max (ByVal Expr As String, ByVal Domain As String, Optional ByVal Criteria As Variant) As Variant
DMax-Recordset-Ersatzfunktion.
Function | Min (ByVal Expr As String, ByVal Domain As String, Optional ByVal Criteria As Variant) As Variant
DMin-Recordset-Ersatzfunktion.
Function | Sum (ByVal Expr As String, ByVal Domain As String, Optional ByVal Criteria As Variant) As Variant
DSum-Recordset-Ersatzfunktion.
Function | InsertIdentityReturn (ByVal InsertSQL As String) As Variant
Insert-SQL-Anweisung ausführen und letzten Identity-Wert (Autowert) zurückgeben.

Ausführliche Beschreibung

DAO-Zugriffsmethoden.

Autor:
Josef Poetzl

Dokumentation der Elementfunktionen

Function Count | ( | ByVal Expr As | String,
 |  | ByVal Domain As | String,
 |  | Optional ByVal Criteria As | Variant
 | ) |  |

DCount-Recordset-Ersatzfunktion.

Parameter:
Expr | Feldname oder berechneter Ausdruck (Select-Teil)
Domain | Tabelle, Abfrage oder SQL-Ausdruck für Sub-Abfrage (FROM-Teil)
Criteria | Filter (WHERE-Teil)
Rückgabe:
Long
Property Set CurrentDb ( ByRef NewCurrentDb As DAO. Database )

Übergabe der DAO-Database-Referenz.

Parameter:
NewCurrentDb Database-Referenz, die als "CurrentDb" verwendet werden soll
Rückgabe:
DAO.Database
Property Get CurrentDb ( )

CurrentDbC-Variante.

Rückgabe:
DAO.Database

CurrentDbC-Variante, die zum Unterschied zur Original-Version von Michael Kaplan die DAO-Database-Referenz nicht automatisch auf Access.Application.CurrentDb setzt, sondern über ein Ereignis anfordert, falls noch keine Referenz vorhanden ist. Dadurch kann über die Hauptanwendung eine belibige Database-Referenz übergeben werden. (z. B. falls eine Temp-Datenbank als CurrentDb dienen soll)

Event ErrorMissingCurrentDb | ( | ByVal Msg As | String,
 |  | ByRef NewCurrentDbRef As DAO. | Database
 | ) |  |

Ereignis für fehlende CurrentDb-Referenz.

Parameter:
Msg | Meldung über Ursache der Ereignisauslösung. (Wird noch nicht genutzt)
NewCurrentDbRef | DAO.Database-Referenz, die für CurrentDb verwendet werden soll

über den ByRef-Parameter NewCurrentDbRef kann die passende DAO.Database-Referenz weitergegeben werden.

Function Execute | ( | ByVal Query As | String,
 |  | Optional ByVal Options As DAO. | RecordsetOptionEnum
 | ) |  |

SQL-Anweisung ausführen.

Parameter:
CommandText SQL-Anweisung
Options
Rückgabe:
Long (Anzahl der betroffenen Datensätze)
Function ExecuteParamSQL | ( | ByVal SqlText As | String,
 |  | ParamArray ParamValues() As | Variant
 | ) |  |

Sql-Anweisung mit Parametern ausführen.

Parameter:
SqlText | SQL-Anweisung
ParamValues | Parmeterwerte in passender Reihenfolge
Rückgabe:
Long (Anzahl der betroffenen Datensätze)
Function ExecuteQueryDef | ( | ByVal qdf As DAO. | QueryDef,
 |  | Optional ByVal QdfParamDefs As | Variant
 | ) |  |

Gespeicherte Abfrage (optional mit Parametern) ausführen.

Parameter:
Qdf | QueryDef-Referenz
QueryParamDefs | 2-dimensionales Parameter-Array (Array(n,1) ... x(n,0) = Parametername, x(n,1) = Parameterwert)
Rückgabe:
Long (Anzahl der betroffenen Datensätze)
Function ExecuteQueryDefByName | ( | ByVal QueryName As | String,
 |  | Optional ByVal QueryParamDefs As | Variant
 | ) |  |

Gespeicherte Abfrage (optional mit Parametern) ausführen.

Parameter:
QueryName | Name der gespeicherten Abfrage (QueryDef)
QueryParamDefs | 2-dimensionales Parameter-Array (Array(n,1) ... x(n,0) = Parametername, x(n,1) = Parameterwert)
Rückgabe:
Long (Anzahl der betroffenen Datensätze)
Function InsertIdentityReturn ( ByVal InsertSQL As String )

Insert-SQL-Anweisung ausführen und letzten Identity-Wert (Autowert) zurückgeben.

Parameter:
InsertSQL Insert-SQL-Anweisung (INSERT ...)
Rückgabe:
Identity-Wert oder NULL falls kein Datensatz angefügt wurde

Funktioniert erst ab Jet 4.0 (Access 2000) und ist vom DBMS abhängig. Bei MySQL-Tabellen wird z. B. 0 zurückgegeben. (Die ADODB-Variante dieser Methode ist bezüglich Einsatz für aktive DBMS besser geeignet.)

Function Lookup | ( | ByVal Expr As | String,
 |  | ByVal Domain As | String,
 |  | Optional ByVal Criteria As | Variant,
 |  | Optional ByVal ValueIfNull As | Variant = Null
 | ) |  |

Lookup-Recordset-Ersatzfunktion.

Parameter:
Expr | Feldname oder berechneter Ausdruck (Select-Teil)
Domain | Tabelle, Abfrage oder SQL-Ausdruck für Sub-Abfrage (FROM-Teil)
Criteria | Filter (WHERE-Teil)
Rückgabe:
Variant
Function LookupSQL | ( | ByVal SqlText As | String,
 |  | Optional ByVal Index As | Variant = 0 &,
 |  | Optional ByVal ValueIfNull As | Variant = Null
 | ) |  |

Lookup-Recordset-Ersatzfunktion für die Übergabe einer vollständigen SQL-Anweisung.

Parameter:
SqlText | SQL-Anweisung
Index | Feldauswahl, falls nicht das erste Feld des Recordsets zurückgegeben werden soll
ValueIfNull | Rückgabewert bei fehlendem Datensatz oder NULL-Feldwert (Standard: Null
Rückgabe:
Variant

Die SQL-Anweisung ist im Jet-SQL-Dialekt zu schreiben.

Function Max | ( | ByVal Expr As | String,
 |  | ByVal Domain As | String,
 |  | Optional ByVal Criteria As | Variant
 | ) |  |

DMax-Recordset-Ersatzfunktion.

Parameter:
Expr | Feldname oder berechneter Ausdruck (Select-Teil)
Domain | Tabelle, Abfrage oder SQL-Ausdruck für Sub-Abfrage (FROM-Teil)
Criteria | Filter (WHERE-Teil)
Rückgabe:
Variant
Function Min | ( | ByVal Expr As | String,
 |  | ByVal Domain As | String,
 |  | Optional ByVal Criteria As | Variant
 | ) |  |

DMin-Recordset-Ersatzfunktion.

Parameter:
Expr | Feldname oder berechneter Ausdruck (Select-Teil)
Domain | Tabelle, Abfrage oder SQL-Ausdruck für Sub-Abfrage (FROM-Teil)
Criteria | Filter (WHERE-Teil)
Rückgabe:
Variant
Function OpenRecordset | ( | ByVal Source As | String,
 |  | Optional ByVal RecordsetType As DAO. | RecordsetTypeEnum = dbOpenDynaset,
 |  | Optional ByVal RecordsetOptions As DAO. | RecordsetOptionEnum = DAO.RecordsetOptionEnum.dbSeeChanges,
 |  | Optional ByVal LockEdit As DAO. | LockTypeEnum = DAO.LockTypeEnum.dbOptimistic
 | ) |  |

Recordset öffnen.

Parameter:
Source | SQL-Anweisung oder Tabllen- bzw. Abfragename
RecordsetType | DAO.RecordsetTypeEnum (Standard: dbOpenDynaset)
RecordsetOptions | DAO.RecordsetOptionEnum (Standard: dbSeeChanges)
LockEdit | DAO.LockTypeEnum (Standard: dbOptimistic)
Rückgabe:
DAO.Recordset
Function OpenRecordsetParamSQL | ( | ByVal ParamSqlText As | String,
 |  | ByVal RecordsetType As DAO. | RecordsetTypeEnum,
 |  | ByVal Options As DAO. | RecordsetOptionEnum,
 |  | ByVal LockEdit As DAO. | LockTypeEnum,
 |  | ParamArray ParamValues() As | Variant
 | ) |  |

Parameter-SQL-Anweisung öffnen (verwendet temporäres QueryDef)

Parameter:
ParamSqlText | SQL-Anweisung mit Parameter (Parameters-Deklaration)
RecordsetType | DAO.RecordsetTypeEnum (Standard: dbOpenDynaset)
RecordsetOptions | DAO.RecordsetOptionEnum (Standard: dbSeeChanges)
LockEdit | DAO.LockTypeEnum (Standard: dbOptimistic)
ParamValues | Parmeterwerte in passender Reihenfolge
Rückgabe:
DAO.Recordset
Function OpenRecordsetQueryDef | ( | ByVal qdf As DAO. | QueryDef,
 |  | Optional ByVal QdfParamDefs As | Variant,
 |  | Optional ByVal RecordsetType As DAO. | RecordsetTypeEnum,
 |  | Optional ByVal Options As DAO. | RecordsetOptionEnum,
 |  | Optional ByVal LockEdit As DAO. | LockTypeEnum
 | ) |  |

Recordset von gespeicherter Abfrage (optional mit Parametern) öffnen.

Parameter:
Qdf | QueryDef-Referenz
QueryParamDefs | 2-dimensionales Parameter-Array (Array(n,1) ... x(n,0) = Parametername, x(n,1) = Parameterwert)
RecordsetType | DAO.RecordsetTypeEnum (Standard: dbOpenDynaset)
RecordsetOptions | DAO.RecordsetOptionEnum (Standard: dbSeeChanges)
LockEdit | DAO.LockTypeEnum (Standard: dbOptimistic)
Rückgabe:
DAO.Recordset
Function OpenRecordsetQueryDefByName | ( | ByVal QueryName As | String,
 |  | Optional ByVal QueryParamDefs As | Variant,
 |  | Optional ByVal RecordsetType As DAO. | RecordsetTypeEnum,
 |  | Optional ByVal Options As DAO. | RecordsetOptionEnum,
 |  | Optional ByVal LockEdit As DAO. | LockTypeEnum
 | ) |  |

Recordset von gespeicherter Abfrage (optional mit Parametern) öffnen.

Parameter:
QueryName | Name der gespeicherten Abfrage (QueryDef)
QueryParamDefs | 2-dimensionales Parameter-Array (Array(n,1) ... x(n,0) = Parametername, x(n,1) = Parameterwert)
RecordsetType | DAO.RecordsetTypeEnum (Standard: dbOpenDynaset)
RecordsetOptions | DAO.RecordsetOptionEnum (Standard: dbSeeChanges)
LockEdit | DAO.LockTypeEnum (Standard: dbOptimistic)
Rückgabe:
DAO.Recordset
Function Sum | ( | ByVal Expr As | String,
 |  | ByVal Domain As | String,
 |  | Optional ByVal Criteria As | Variant
 | ) |  |

DSum-Recordset-Ersatzfunktion.

Parameter:
Expr | Feldname oder berechneter Ausdruck (Select-Teil)
Domain | Tabelle, Abfrage oder SQL-Ausdruck für Sub-Abfrage (FROM-Teil)
Criteria | Filter (WHERE-Teil)
Rückgabe:
Variant
Die Dokumentation für diese Klasse wurde erzeugt aufgrund der Datei:
  • DaoHandler.cls


DBMS Connection Wizard: DbConnectionHandler Klassenreferenz

  • Auflistung der Klassen
  • Klassen-Verzeichnis
  • Klassen-Elemente
Öffentliche Methoden

DbConnectionHandler Klassenreferenz

Datenbankverbindung per ADO oder DAO (inkl. ODBC) Mehr ...

Aufstellung aller Elemente

Öffentliche Methoden

Event | ErrorMissingCurrentDb (ByVal Msg As String, ByRef NewCurrentDbRef As DAO.Database)
Ereignis für fehlende CurrentDb-Referenz (Weitergabe des DaoHandler- bzw. OdbcHandler-Ereignisses: ErrorMissingCurrentDb)
Event | ErrorMissingCurrentConnection (ByVal Msg As String, ByRef NewCurrentConnection As ADODB.Connection)
Ereignis für fehlende ADODB-Connection-Referenz (Weitergabe des AdodbHandler-Ereignisses: ErrorMissingCurrentConnection)
Event | ErrorEmptyOledbConnectionString (ByVal Msg As String, ByRef NewConnectionString As String)
Ereignis für fehlenden OLEDB-Connectionstring (Weitergabe des AdodbHandler-Ereignisses: ErrorEmptyOledbConnectionString)
Event | ErrorEmptyOdbcConnectionString (ByVal Msg As String, ByRef NewConnectionString As String)
Ereignis für fehlenden ODBC-Connectionstring (Weitergabe des OdbcHandler-Ereignisses: ErrorEmptyConnectionString)
Event | Disposed ()
Ereignis-Meldung wenn Objektreferenzen entfernt wurden.
Sub | Dispose ()
Objektreferenzen entfernen.
ADO

ADO-Zugriff

Property Get | ADODB () As AdodbHandler
ADODB-Zugriffsmethoden.
Property Get | CurrentConnection () As ADODB.Connection
ADODB-Connection zur akutellen DBSM-Verbindung = Me.ADODB.CurrentConnection
Property Set | CurrentConnection (ByRef NewConnection As ADODB.Connection)
CurrentConnection = Me.ADODB.CurrentConnection
Property Get | OledbConnectionString () As String
OledbConnectionString = Me.ADODB.ConnectionString
Property Let | OledbConnectionString (ByVal sConnectionString As String)
OledbConnectionString = Me.ADODB.ConnectionString
DAO

DAO-Zugriff

Property Get | DAO () As DaoHandler
DAO-Zugriffsmethoden.
Property Get | CurrentDb () As DAO.Database
CurrentDb = Me.DAO.CurrentDb
Property Set | CurrentDb (ByRef NewCurrentDb As DAO.Database)
CurrentDb = Me.DAO.CurrentDb
ODBC

ODBC-Zugriff

Property Get | ODBC () As OdbcHandler
ODBC-Zugriffsmethoden.
Property Get | OdbcConnectionString () As String
ODBC-ConnectionString = Me.ODBC.ConnectionString
Property Let | OdbcConnectionString (ByVal sConnectionString As String)
ODBC-ConnectionString = Me.ODBC.ConnectionString
Property Get | CurrentDbBE () As DAO.Database
CurrentDbBE = Me.ODBC.CurrentDbBE
Property Set | CurrentDbBE (ByRef NewCurrentDbBE As DAO.Database)
CurrentDbBE = Me.ODBC.CurrentDbBE

Ausführliche Beschreibung

Datenbankverbindung per ADO oder DAO (inkl. ODBC)

Vereinheitlicht ADO- und DAO-Methoden

Dokumentation der Elementfunktionen

Property Get ADODB ( )

ADODB-Zugriffsmethoden.

Rückgabe:
AdodbHandler
Property Get CurrentConnection ( )

ADODB-Connection zur akutellen DBSM-Verbindung = Me.ADODB.CurrentConnection

Rückgabe:
ADODB.Connection
Property Set CurrentConnection ( ByRef NewConnection As ADODB. Connection )

CurrentConnection = Me.ADODB.CurrentConnection

Parameter:
NewConnection Neue ADO-Connection
Property Get CurrentDb ( )

CurrentDb = Me.DAO.CurrentDb

Rückgabe:
DAO.Database
Property Set CurrentDb ( ByRef NewCurrentDb As DAO. Database )

CurrentDb = Me.DAO.CurrentDb

Parameter:
NewCurrentDb DAO.Database-Referenz die für CurrentDb verwendet werden soll
Rückgabe:
DAO.Database
Property Set CurrentDbBE ( ByRef NewCurrentDbBE As DAO. Database )

CurrentDbBE = Me.ODBC.CurrentDbBE

Parameter:
NewCurrentDbBE DAO.Database-Referenz auf eine bereits geöffnete Datanbank
Rückgabe:
DAO.Database
Property Get CurrentDbBE ( )

CurrentDbBE = Me.ODBC.CurrentDbBE

Rückgabe:
DAO.Database auf ODBC-Datenbank
Property Get DAO ( )

DAO-Zugriffsmethoden.

Rückgabe:
DaoHandler
Event ErrorEmptyOdbcConnectionString | ( | ByVal Msg As | String,
 |  | ByRef NewConnectionString As | String
 | ) |  |

Ereignis für fehlenden ODBC-Connectionstring (Weitergabe des OdbcHandler-Ereignisses: ErrorEmptyConnectionString)

Parameter:
Msg | Meldung über Ursache der Ereignisauslösung. (Wird noch nicht genutzt)
NewConnectionString | ODBC-Connectionstring

über den ByRef-Parameter NewConnectionString kann der passende ODBC-Connectionstring weitergegeben werden.

Event ErrorEmptyOledbConnectionString | ( | ByVal Msg As | String,
 |  | ByRef NewConnectionString As | String
 | ) |  |

Ereignis für fehlenden OLEDB-Connectionstring (Weitergabe des AdodbHandler-Ereignisses: ErrorEmptyOledbConnectionString)

Parameter:
Msg | Meldung über Ursache der Ereignisauslösung. (Wird noch nicht genutzt)
NewConnectionString | OLEDB-Connectionstring

über den ByRef-Parameter NewConnectionString kann der passende OLEDB-Connectionstring weitergegeben werden.

Event ErrorMissingCurrentConnection | ( | ByVal Msg As | String,
 |  | ByRef NewCurrentConnection As ADODB. | Connection
 | ) |  |

Ereignis für fehlende ADODB-Connection-Referenz (Weitergabe des AdodbHandler-Ereignisses: ErrorMissingCurrentConnection)

Parameter:
Msg | Meldung über Ursache der Ereignisauslösung. (Wird noch nicht genutzt)
NewCurrentConnection | ADODB.Connection-Referenz, die für CurrentConnection verwendet werden soll

Über den ByRef-Parameter NewCurrentConnection kann die passende ADODB.Database-Referenz weitergegeben werden. Eine Referenz-Weitergabe ist allerdings nicht zwingend erforderlich, da z. B. in der ADODBHandler-Methode CurrentConnection die Connection dann aus dem ConnectionString erstellt wird.

Event ErrorMissingCurrentDb | ( | ByVal Msg As | String,
 |  | ByRef NewCurrentDbRef As DAO. | Database
 | ) |  |

Ereignis für fehlende CurrentDb-Referenz (Weitergabe des DaoHandler- bzw. OdbcHandler-Ereignisses: ErrorMissingCurrentDb)

Parameter:
Msg | Meldung über Ursache der Ereignisauslösung. (Wird noch nicht genutzt)
NewCurrentDbRef | DAO.Database-Referenz, die für CurrentDb verwendet werden soll

über den ByRef-Parameter NewCurrentDbRef kann die passende DAO.Database-Referenz weitergegeben werden.

Property Get ODBC ( )

ODBC-Zugriffsmethoden.

Rückgabe:
OdbcHandler
Property Get OdbcConnectionString ( )

ODBC-ConnectionString = Me.ODBC.ConnectionString

Rückgabe:
String
Property Get OledbConnectionString ( )

OledbConnectionString = Me.ADODB.ConnectionString

Rückgabe:
String
Die Dokumentation für diese Klasse wurde erzeugt aufgrund der Datei:
  • DbConnectionHandler.cls


DBMS Connection Wizard: DbConnectionInfo Klassenreferenz

  • Auflistung der Klassen
  • Klassen-Verzeichnis
  • Klassen-Elemente
Öffentliche Methoden

DbConnectionInfo Klassenreferenz

Hilfsklasse zur Einstellung der Verbingungsparameter. Mehr ...

Aufstellung aller Elemente

Öffentliche Methoden

Event | DbmsConnectionChanged (ByVal newCID As String)
Ereignis wenn sich die Verbindung ändert.
Event | DbmsConnectionInfoCleared ()
Ereignis wenn sich die Verbindung ändert.
Event | DbmsInfoMessage (ByVal Source As String, ByVal Msg As String, ByVal MsgStyle As VbMsgBoxStyle)
Ereignis zur Weitergabe von Informationen.
Function | CheckConnection (Optional ByRef ErrMsg As String=vbNullString) As Boolean
Verbindung zum Server bzw. Datenbank prüfen.
Property Get | OledbConnectionString () As String
OledbConnectionString.
Property Get | OdbcConnectionString (Optional ByVal bWithoutUserInfo As Boolean=False) As String
OdbcConnectionString.
Property Get | DbUser (Optional ByVal withoutServerCheck As Boolean=False) As String
Name des Datenbankbenutzers.
Property Get | DbUserPassword () As String
Passwort des Datenbankbenutzers, das bei Anmeldung eingegeben wurde.
Property Get | SavePassword () As Boolean
Einstellung aus den Verbindungsparametern, ob Passwort bei verknüpften Tabellen gespeichert werden soll.
Property Get | UseLoginForm () As Boolean
Einstellung aus den Verbindungsparametern, ob beim Anmelden das Login-Formular verwendet werden soll.
Sub | ClearConnectionInfo ()
Eingestellte Verbindungsparameter löschen.
Function | ChangeDbUserPassword (ByVal NewPassword As String, ByVal OldPassword As String, Optional ByVal LoginName As String=vbNullString, Optional ByRef Msg As String) As Boolean
Datenbankpasswort des Benutzers ändern.
Property Get | PermanentBackendRstSqlText () As String
Select-Anweisung für ODBC-Recordsetverbindung zum Aufrechterhalten der Verbindung.
Property Get | ConnectionStrings () As DbmsConnectionStrings
ODBC- und OLEDB-Connectionstring.
Property Get | TableListSqlText () As String
SQL-Anweisung im SQL-Dialtekt des DBMS zur Auflistung der im DBS enthaltenen Tabellen.
Function | ParseTableName (ByVal sTabName As String) As String
Hilfsprozedur zum Anpassen des Tabellennamens.

Ausführliche Beschreibung

Hilfsklasse zur Einstellung der Verbingungsparameter.

Dokumentation der Elementfunktionen

Function ChangeDbUserPassword | ( | ByVal NewPassword As | String,
 |  | ByVal OldPassword As | String,
 |  | Optional ByVal LoginName As | String = vbNullString,
 |  | Optional ByRef Msg As | String
 | ) |  |

Datenbankpasswort des Benutzers ändern.

Parameter:
NewPassword | Neues Passwort
OldPassword | Altes Passwort
LoginName | Benutzername (Falls kein Benutzername übergeben wird, wird der aktuelle Benutzer eingesetzt)
Msg | ByRef-Parameter zur Rückgabe einer Fehlermeldung, falls das Passwort nicht geändert werden könnte
Rückgabe:
Boolean: True = Passwort wurde geändert
Function CheckConnection ( Optional ByRef ErrMsg As String = vbNullString )

Verbindung zum Server bzw. Datenbank prüfen.

Parameter:
ErrMsg Fehlermeldung vom ADODB- bzw. ODBC-Verbindungsaufbau
Rückgabe:
Boolean: True = Ado- und ODBC-Verbindung konnten aufgebaut werden

Als erster Test erfolgt der ADO-Verbindungsaufbau. Sobald dieser erfolgreich war, wird der ODBC-Verbindungsaufbau getestet.

Sub ClearConnectionInfo ( )

Eingestellte Verbindungsparameter löschen.

Erfordert erneutes Einlesen aus Tabelle, wenn die Verbidnungsdaten angefordert werden.

Property Get ConnectionStrings ( )

ODBC- und OLEDB-Connectionstring.

Rückgabe:
DbmsConnectionStrings

Diese Prozedur muss erweitert werden, wenn weitere DBMS (wie Oracle) eingesetzt werden sollen.

Event DbmsConnectionChanged ( ByVal newCID As String )

Ereignis wenn sich die Verbindung ändert.

Parameter:
ErrNumber | Fehlernummer
Source | Prozedur(en) in der der Fehler auftrat
ErrDescription | Fehlerbeschreibung
Response | AcUtilErrorResumeMode-Wert (ermöglich Fehlersteuerung als Reaktion auf das Ereignis)

Kann nützlich sein, wenn in Abhängigkeit der Verbindung Anzeigen aktualisiert werden usw.

Event DbmsConnectionInfoCleared ( )

Ereignis wenn sich die Verbindung ändert.

Parameter:
ErrNumber | Fehlernummer
Source | Prozedur(en) in der der Fehler auftrat
ErrDescription | Fehlerbeschreibung
Response | AcUtilErrorResumeMode-Wert (ermöglich Fehlersteuerung als Reaktion auf das Ereignis)

Kann nützlich sein, wenn in Abhängigkeit der Verbindung Anzeigen aktualisiert werden usw.

Event DbmsInfoMessage | ( | ByVal Source As | String,
 |  | ByVal Msg As | String,
 |  | ByVal MsgStyle As | VbMsgBoxStyle
 | ) |  |

Ereignis zur Weitergabe von Informationen.

Parameter:
ErrNumber | Fehlernummer
Source | Prozedur(en) in der der Fehler auftrat
ErrDescription | Fehlerbeschreibung
Response | AcUtilErrorResumeMode-Wert (ermöglich Fehlersteuerung als Reaktion auf das Ereignis)

Dient zur Weitergabe von Infos (ähnlich debug.print)

Property Get DbUser ( Optional ByVal withoutServerCheck As Boolean = False )

Name des Datenbankbenutzers.

Parameter:
withoutServerCheck True = Keine Prüfung durchführen, ob Verbidnungsdaten bereits eingelesen wurden
Rückgabe:
String
Property Get DbUserPassword ( )

Passwort des Datenbankbenutzers, das bei Anmeldung eingegeben wurde.

'nicht exportieren (2. * für Export fehlt)

Rückgabe:
String

Das Passwort sollte normalerweise nie abgefragt werden müssen und nur zur Weitergabe innerhalb der Klassenstruktur benutzt werden.

Property Get OdbcConnectionString ( Optional ByVal bWithoutUserInfo As Boolean = False )

OdbcConnectionString.

Parameter:
bWithoutUserInfo False = Benutzerkennung ist im ODBC-Connectionstring nethalten, True = ohne Benutzerkennung
Rückgabe:
String

Das Einstellen des Parameters bWithoutUserInfo ist normalerweise nicht erforderlich, kann jedoch hilfreich sein, falls der ODBC-Connectionstring ohne Passwort angezeigt werden soll.

Property Get OledbConnectionString ( )

OledbConnectionString.

Rückgabe:
String
Function ParseTableName ( ByVal sTabName As String )

Hilfsprozedur zum Anpassen des Tabellennamens.

Parameter:
sTabName Tabellename
Rückgabe:
String

Bei manchen DBMS muss Groß- o. Kleinschreibung beachtet bzw. der Name mit Sonderzeichen eingeklammert werden.

Property Get PermanentBackendRstSqlText ( )

Select-Anweisung für ODBC-Recordsetverbindung zum Aufrechterhalten der Verbindung.

Rückgabe:
String

Diese Prozedur muss erweitert werden, wenn weitere DBMS (wie Oracle) eingesetzt werden sollen.

Property Get SavePassword ( )

Einstellung aus den Verbindungsparametern, ob Passwort bei verknüpften Tabellen gespeichert werden soll.

Rückgabe:
Boolean
Property Get TableListSqlText ( )

SQL-Anweisung im SQL-Dialtekt des DBMS zur Auflistung der im DBS enthaltenen Tabellen.

Rückgabe:
String

Diese Prozedur muss erweitert werden, wenn weitere DBMS (wie Oracle) eingesetzt werden sollen.

Property Get UseLoginForm ( )

Einstellung aus den Verbindungsparametern, ob beim Anmelden das Login-Formular verwendet werden soll.

Rückgabe:
Boolean
Die Dokumentation für diese Klasse wurde erzeugt aufgrund der Datei:
  • DbConnectionInfo.cls


DBMS Connection Wizard: DbConnectionManager Klassenreferenz

  • Auflistung der Klassen
  • Klassen-Verzeichnis
  • Klassen-Elemente
Öffentliche Methoden

DbConnectionManager Klassenreferenz

Klasse zur Instanzierung, Terminierung und Basissteuerung von Hilfsklassen. Mehr ...

Aufstellung aller Elemente

Öffentliche Methoden

Function | CheckConnectionStatus () As Boolean
Testen, ob Verbindungsaufbau möglich ist.
Property Get | ConnectionInfo () As DbConnectionInfo
DbConnectionInfo-Instanz der Anwendung.
Property Get | DbConnection () As DbConnectionHandler
DbConnectionHandler-Instanz = oberste Ebene der Zugriffsstruktur.

Ausführliche Beschreibung

Klasse zur Instanzierung, Terminierung und Basissteuerung von Hilfsklassen.

In dieser Klasse wird u. ä. auf die Ereignisse der DbConnectionInfo- u. DbConnectionHandler-Instanz reagiert

Dokumentation der Elementfunktionen

Function CheckConnectionStatus ( )

Testen, ob Verbindungsaufbau möglich ist.

Rückgabe:
Boolean: True = Verbindungsaufbau war erfolgreich
Property Get ConnectionInfo ( )

DbConnectionInfo-Instanz der Anwendung.

Rückgabe:
DbConnectionInfo

Dient zum Ausgeben von Informationen zur Datenbankverbindung

Property Get DbConnection ( )

DbConnectionHandler-Instanz = oberste Ebene der Zugriffsstruktur.

Rückgabe:
DbConnectionHandler

Kapselt ADODB- und DAO-Methoden sowie ODBC-Zugriffe

Die Dokumentation für diese Klasse wurde erzeugt aufgrund der Datei:
  • DbConnectionManager.cls


DBMS Connection Wizard: DbmsConnectionStrings Strukturreferenz

  • Auflistung der Klassen
  • Klassen-Verzeichnis
  • Klassen-Elemente
  • defGlobal_DBMS
  • DbmsConnectionStrings

DbmsConnectionStrings Strukturreferenz

Type für die gleichzeitige Übergabe der Connectionsstrings. Mehr ...

Aufstellung aller Elemente

Ausführliche Beschreibung

Type für die gleichzeitige Übergabe der Connectionsstrings.

OledbConnectionString | OLEDB-Connectionstring für ADODB-Verbindung
OdbcConnectionString | ODBC-Connectionstring für DAO-Verbindung
DatabaseFile | Datenbankdateiname inkl. Pfad falls ein File-Backend eingesetzt wird
Die Dokumentation für diese Struktur wurde erzeugt aufgrund der Datei:
  • defGlobal_DBMS.bas


DBMS Connection Wizard: Form_frmConfig_DBMS Klassenreferenz

  • Auflistung der Klassen
  • Klassen-Verzeichnis
  • Klassen-Elemente

Form_frmConfig_DBMS Klassenreferenz

Form_frmConfig_DBMS. Mehr ...

Aufstellung aller Elemente

Ausführliche Beschreibung

Form_frmConfig_DBMS.

Die Dokumentation für diese Klasse wurde erzeugt aufgrund der Datei:
  • Form_frmConfig_DBMS.frm


DBMS Connection Wizard: OdbcHandler Klassenreferenz

  • Auflistung der Klassen
  • Klassen-Verzeichnis
  • Klassen-Elemente
Öffentliche Methoden

OdbcHandler Klassenreferenz

ODBC-Zugriffsmethoden. Mehr ...

Aufstellung aller Elemente

Öffentliche Methoden

Event | ErrorMissingCurrentDb (ByVal Msg As String, ByRef NewCurrentDbRef As DAO.Database)
Ereignis für fehlende CurrentDb-Referenz.
Event | ErrorEmptyConnectionString (ByVal Msg As String, ByRef NewConnectionString As String)
Ereignis für fehlenden ODBC-Connectionstring.
Event | DbObjectRelinked (ByVal LastDbObjectName As String, ByVal lCounter As Long)
Info über das zuletzt verknüpfte Element.
Event | DbObjectDeleted (ByVal LastDbObjectName As String, ByVal lCounter As Long)
Info über das zuletzt gelöschte Element.
Event | HookInsertIdentityReturn (ByRef InsertSQL As String, ByRef ActiveDb As DAO.Database, ByRef IdentitySelectString As String, ByRef ResponseMode As Long, ByRef ResponseMessage As Variant)
Event zum Anfagen von InsertIdentityReturn um die Sql-Anweisung zu ändern bzw. Ergebnis von außen einfließen zu lassen.
Property Get | CurrentDb () As DAO.Database
DAO.Database-Instanz des Frontends bzw. jener Jet-DB in der die Pass-Through-Abfragen erstellt werden sollen.
Property Set | CurrentDb (ByRef NewCurrentDb As DAO.Database)
DAO.Database-Instanz des Frontends bzw. jener Jet-DB in der die Pass-Through-Abfragen erstellt werden sollen.
Property Get | CurrentDbBE () As DAO.Database
Database-Referenz zum Backend.
Property Set | CurrentDbBE (ByRef NewCurrentDbBE As DAO.Database)
Database-Referenz zum Backend.
Property Get | ConnectionString () As String
ODBC-ConnectionString.
Property Let | ConnectionString (ByVal Value As String)
ODBC-ConnectionString.
Function | OpenRecordset (ByVal Source As String, Optional ByVal RecordsetType As DAO.RecordsetTypeEnum=dbOpenForwardOnly, Optional ByVal RecordsetOptions As DAO.RecordsetOptionEnum=DAO.RecordsetOptionEnum.dbSeeChanges, Optional ByVal LockEdit As DAO.LockTypeEnum=DAO.LockTypeEnum.dbOptimistic) As DAO.Recordset
openRecordset
Function | OpenRecordsetPT (ByVal Source As String, Optional ByVal RecordsetType As DAO.RecordsetTypeEnum=dbOpenForwardOnly, Optional ByVal RecordsetOptions As DAO.RecordsetOptionEnum=DAO.RecordsetOptionEnum.dbSeeChanges Or DAO.RecordsetOptionEnum.dbSQLPassThrough, Optional ByVal LockEdit As DAO.LockTypeEnum=DAO.LockTypeEnum.dbOptimistic) As DAO.Recordset
OpenRecordsetPT.
Function | Execute (ByVal CommandText As String, Optional ByVal Options As DAO.RecordsetOptionEnum) As Long
DAO.Execute-Anweisung über CurrentDbBE.
Function | ExecutePT (ByVal CommandText As String, Optional ByVal Options As DAO.RecordsetOptionEnum=DAO.RecordsetOptionEnum.dbSQLPassThrough) As Long
Execute-Anweisung über eine Pass-Through-Abfrage.
Function | LookupSQL (ByVal SqlText As String, Optional ByVal Index As Variant=0 &, Optional ByVal ValueIfNull As Variant=Null) As Variant
Lookup-Recordset-Ersatzfunktion für die Übergabe einer kompletten SQL-Anweisung.
Function | LookupSqlPT (ByVal SqlText As String, Optional ByVal Index As Variant=0 &, Optional ByVal ValueIfNull As Variant=Null) As Variant
Lookup-Recordset-Ersatzfunktion für die Übergabe einer kompletten SQL-Anweisung.
Function | Lookup (ByVal Expr As String, ByVal Domain As String, Optional ByVal Criteria As Variant, Optional ByVal ValueIfNull As Variant=Null) As Variant
Lookup-Recordset-Ersatzfunktion.
Function | Count (ByVal Expr As String, ByVal Domain As String, Optional ByVal Criteria As Variant) As Variant
DCount-Recordset-Ersatzfunktion.
Function | Max (ByVal Expr As String, ByVal Domain As String, Optional ByVal Criteria As Variant) As Variant
DMax-Recordset-Ersatzfunktion.
Function | Min (ByVal Expr As String, ByVal Domain As String, Optional ByVal Criteria As Variant) As Variant
DMin-Recordset-Ersatzfunktion.
Function | Sum (ByVal Expr As String, ByVal Domain As String, Optional ByVal Criteria As Variant) As Variant
DSum-Recordset-Ersatzfunktion.
Function | InsertIdentityReturn (ByVal InsertSQL As String) As Variant
Insert-SQL-Anweisung ausführen und letzten Identity-Wert (Autowert) zurückgeben.
Sub | LinkTable (ByVal SourceTableName As String, Optional ByVal LinkedTableName As String=vbNullString, Optional ByVal SavePWD As Boolean=False, Optional ByVal RemoveSchemaName As Boolean=True)
Backend-Tabelle im Access-Frontend verknüpfen.
Function | RelinkTables (Optional ByVal SavePWD As Boolean=False, Optional ByVal EventPeriod As Long=0) As Long
RelinkTables.
Function | RelinkTable (ByVal LinkedTableName As String, Optional ByVal SavePWD As Boolean=False) As Boolean
Verküpfte Tabelle mit möglicher Änderung der Server-Daten neu verknüpfen.
Function | RelinkPassThroughQueries (Optional ByVal SavePWD As Boolean=False, Optional ByVal EventPeriod As Long=0) As Long
Alle Pass-Through-Abfragen neu verknüpfen.
Function | RelinkPassThroughQuery (ByVal QueryName As String, Optional ByVal SavePWD As Boolean=False) As Boolean
Pass-Through-Abfrage neu verknüpfen.
Function | RelinkTablesAndQueries (Optional ByVal SavePWD As Boolean=False, Optional ByVal EventPeriod As Long=0) As Long
Alle verknüpften Tabellen und Pass-Through-Abfragen neu verknüpfen.
Function | DeleteOdbcTableDefs (Optional ByVal EventPeriod As Long=0) As Long
Alle verknüpften Tabelle im Frontend löschen. (Hat keine Auswirkung auf die Backend-Tabellen.)

Ausführliche Beschreibung

ODBC-Zugriffsmethoden.

Autor:
Josef Poetzl

Dokumentation der Elementfunktionen

Property Get ConnectionString ( )

ODBC-ConnectionString.

Rückgabe:
String
Property Let ConnectionString ( ByVal Value As String )

ODBC-ConnectionString.

Parameter:
Value ODBC-Connectionstring für Verbindungsaufbau

Beispiel: "ODBC;DRIVER={SQL Server};DATABASE=testdb;SERVER=(local)\SQL2005;Trusted_Connection=Yes;"

Function Count | ( | ByVal Expr As | String,
 |  | ByVal Domain As | String,
 |  | Optional ByVal Criteria As | Variant
 | ) |  |

DCount-Recordset-Ersatzfunktion.

Parameter:
Expr | Feldname oder berechneter Ausdruck (Select-Teil)
Domain | Tabelle, Abfrage oder SQL-Ausdruck für Sub-Abfrage (FROM-Teil)
Criteria | Filter (WHERE-Teil)
Rückgabe:
Long
Property Get CurrentDb ( )

DAO.Database-Instanz des Frontends bzw. jener Jet-DB in der die Pass-Through-Abfragen erstellt werden sollen.

Rückgabe:
DAO.Database
Property Set CurrentDb ( ByRef NewCurrentDb As DAO. Database )

DAO.Database-Instanz des Frontends bzw. jener Jet-DB in der die Pass-Through-Abfragen erstellt werden sollen.

Parameter:
NewCurrentDb DAO.Database-Referenz die für CurrentDb verwendet werden soll
Rückgabe:
DAO.Database
Property Get CurrentDbBE ( )

Database-Referenz zum Backend.

Rückgabe:
DAO.Database

DAO.Database wird über DBEngine.OpenDatabase("", dbDriverComplete, False, ConnectionString) geöffnet.

Property Set CurrentDbBE ( ByRef NewCurrentDbBE As DAO. Database )

Database-Referenz zum Backend.

Parameter:
NewCurrentDbBE DAO.Database-Referenz auf eine bereits geöffnete Datanbank
Rückgabe:
DAO.Database

Diese Set-Property-Prozedur ist normalerweise nicht erforderlich, da die Datanbank überlicherweise mittels angegebenen ODBC-Connectionstring geöffnet wird.

Event DbObjectDeleted | ( | ByVal LastDbObjectName As | String,
 |  | ByVal lCounter As | Long
 | ) |  |

Info über das zuletzt gelöschte Element.

Parameter:
LastDbObjectName | Name des zuletzt gelöschten Elements
lCounter | Anzahl der gelöschten Elemente seit Aufruf der Methode

Wird in der Methode DeleteOdbcTableDefs genutzt.

Event DbObjectRelinked | ( | ByVal LastDbObjectName As | String,
 |  | ByVal lCounter As | Long
 | ) |  |

Info über das zuletzt verknüpfte Element.

Parameter:
LastDbObjectName | Meldung über Ursache der Ereignisauslösung. (Wird noch nicht genutzt)
lCounter | Anzahl der verknüpften Elemente seit Aufruf der Methode

Wird in der Methode RelinkTablesAndQueries genutzt.

Function DeleteOdbcTableDefs ( Optional ByVal EventPeriod As Long = 0 )

Alle verknüpften Tabelle im Frontend löschen. (Hat keine Auswirkung auf die Backend-Tabellen.)

Parameter:
lEventCounter Hilfsparamter für Wertübergabe: Anzahl der gelöschen Elemente für DbObjectDeleted-Ereignisaufruf
Rückgabe:
Long (Anzahl der gelöschten Tabellen)

Je nach Einstellung von lEventCounter wird das Ereignis DbObjectDeleted ausgelöst (0 = kein Ereignisaufruf, 1 = nach jedem Element Ereignis auslösen, 5 nach jedem 5. Element Ereignis auslösen,...).

Event ErrorEmptyConnectionString | ( | ByVal Msg As | String,
 |  | ByRef NewConnectionString As | String
 | ) |  |

Ereignis für fehlenden ODBC-Connectionstring.

Parameter:
Msg | Meldung über Ursache der Ereignisauslösung. (Wird noch nicht genutzt)
NewConnectionString | ODBC-Connectionstring

Über den ByRef-Parameter NewConnectionString kann der passende ODBC-Connectionstring weitergegeben werden.

Event ErrorMissingCurrentDb | ( | ByVal Msg As | String,
 |  | ByRef NewCurrentDbRef As DAO. | Database
 | ) |  |

Ereignis für fehlende CurrentDb-Referenz.

Parameter:
Msg | Meldung über Ursache der Ereignisauslösung. (Wird noch nicht genutzt)
NewCurrentDbRef | DAO.Database-Referenz, die für CurrentDb verwendet werden soll

über den ByRef-Parameter NewCurrentDbRef kann die passende DAO.Database-Referenz weitergegeben werden.

Function Execute | ( | ByVal CommandText As | String,
 |  | Optional ByVal Options As DAO. | RecordsetOptionEnum
 | ) |  |

DAO.Execute-Anweisung über CurrentDbBE.

Parameter:
CommandText | SQL-Anweisung im Jet-SQL-Dialekt
Options | Werte von RecordsetOptionEnum analog DAO.Database.Execute
Rückgabe:
Long (Anzahl der betroffenen Datensätze)
Function ExecutePT | ( | ByVal CommandText As | String,
 |  | Optional ByVal Options As DAO. | RecordsetOptionEnum = DAO.RecordsetOptionEnum.dbSQLPassThrough
 | ) |  |

Execute-Anweisung über eine Pass-Through-Abfrage.

Parameter:
CommandText | SQL-Anweisung im SQL-Dialekt des DBMS
Options | Werte von RecordsetOptionEnum analog DAO.CreateQueryDef.Execute
Rückgabe:
Long (Anzahl der betroffenen Datensätze)
Event HookInsertIdentityReturn | ( | ByRef InsertSQL As | String,
 |  | ByRef ActiveDb As DAO. | Database,
 |  | ByRef IdentitySelectString As | String,
 |  | ByRef ResponseMode As | Long,
 |  | ByRef ResponseMessage As | Variant
 | ) |  |

Event zum Anfagen von InsertIdentityReturn um die Sql-Anweisung zu ändern bzw. Ergebnis von außen einfließen zu lassen.

Parameter:
InsertSQL | Insert-SQL-Anweisung (kann mittels Hook geändert werden)
ActiveDb | Aktuell genutzte Datenbank
IdentitySelectString | SQL-Anweisung zum Auswerten des letzen Identity-Wertes (kann mittels Hook geändert werden)
ResponseMode | Anweisung für die Weiterarbeit in der Prozedur
ResponseMessage | Rückgabewert

Wird in der Methode DeleteOdbcTableDefs genutzt.

Function InsertIdentityReturn ( ByVal InsertSQL As String )

Insert-SQL-Anweisung ausführen und letzten Identity-Wert (Autowert) zurückgeben.

Parameter:
InsertSQL Insert-SQL-Anweisung (INSERT ...)
Rückgabe:
Identity-Wert oder NULL falls kein Datensatz angefügt wurde

Funktioniert erst ab Jet 4.0 (Access 2000) und ist vom DBMS abhängig. Bei MySQL-Tabellen wird z. B. 0 zurückgegeben

Sub LinkTable | ( | ByVal SourceTableName As | String,
 |  | Optional ByVal LinkedTableName As | String = vbNullString,
 |  | Optional ByVal SavePWD As | Boolean = False,
 |  | Optional ByVal RemoveSchemaName As | Boolean = True
 | ) |  |

Backend-Tabelle im Access-Frontend verknüpfen.

Parameter:
SourceTableName | Tabelle im Backend
LinkedTableName | Tabelle im Frontend
SavePWD | ODBC-Passwort in Tabellenverknüpfung speichern
RemoveSchemaName | Schema-Kennung entfernen

Sollten eine 2-geteilte Tabellenkennung wie "dbo.Tabelle123" im BE vorliegen und bRemoveSchemaName auf false gesetzt sein, wird der Punkt durch "_" ersetzt.

Function Lookup | ( | ByVal Expr As | String,
 |  | ByVal Domain As | String,
 |  | Optional ByVal Criteria As | Variant,
 |  | Optional ByVal ValueIfNull As | Variant = Null
 | ) |  |

Lookup-Recordset-Ersatzfunktion.

Parameter:
Expr | Feldname oder berechneter Ausdruck (Select-Teil)
Domain | Tabelle, Abfrage oder SQL-Ausdruck für Sub-Abfrage (FROM-Teil)
Criteria | Filter (WHERE-Teil)
Rückgabe:
Variant
Function LookupSQL | ( | ByVal SqlText As | String,
 |  | Optional ByVal Index As | Variant = 0 &,
 |  | Optional ByVal ValueIfNull As | Variant = Null
 | ) |  |

Lookup-Recordset-Ersatzfunktion für die Übergabe einer kompletten SQL-Anweisung.

Parameter:
SqlText | SQL-Anweisung
Index | Feldauswahl, falls nicht das erste Feld des Recordsets zurückgegeben werden soll
ValueIfNull | Rückgabewert bei fehlendem Datensatz oder NULL-Feldwert (Standard: Null
Rückgabe:
Variant
Function LookupSqlPT | ( | ByVal SqlText As | String,
 |  | Optional ByVal Index As | Variant = 0 &,
 |  | Optional ByVal ValueIfNull As | Variant = Null
 | ) |  |

Lookup-Recordset-Ersatzfunktion für die Übergabe einer kompletten SQL-Anweisung.

Parameter:
SqlText | SQL-Anweisung
Index | Feldauswahl, falls nicht das erste Feld des Recordsets zurückgegeben werden soll
ValueIfNull | Rückgabewert bei fehlendem Datensatz oder NULL-Feldwert (Standard: Null
Rückgabe:
Variant
Function Max | ( | ByVal Expr As | String,
 |  | ByVal Domain As | String,
 |  | Optional ByVal Criteria As | Variant
 | ) |  |

DMax-Recordset-Ersatzfunktion.

Parameter:
Expr | Feldname oder berechneter Ausdruck (Select-Teil)
Domain | Tabelle, Abfrage oder SQL-Ausdruck für Sub-Abfrage (FROM-Teil)
Criteria | Filter (WHERE-Teil)
Rückgabe:
Variant
Function Min | ( | ByVal Expr As | String,
 |  | ByVal Domain As | String,
 |  | Optional ByVal Criteria As | Variant
 | ) |  |

DMin-Recordset-Ersatzfunktion.

Parameter:
Expr | Feldname oder berechneter Ausdruck (Select-Teil)
Domain | Tabelle, Abfrage oder SQL-Ausdruck für Sub-Abfrage (FROM-Teil)
Criteria | Filter (WHERE-Teil)
Rückgabe:
Variant
Function OpenRecordset | ( | ByVal Source As | String,
 |  | Optional ByVal RecordsetType As DAO. | RecordsetTypeEnum = dbOpenForwardOnly,
 |  | Optional ByVal RecordsetOptions As DAO. | RecordsetOptionEnum = DAO.RecordsetOptionEnum.dbSeeChanges,
 |  | Optional ByVal LockEdit As DAO. | LockTypeEnum = DAO.LockTypeEnum.dbOptimistic
 | ) |  |

openRecordset

Parameter:
Quelle | SQL-Anweisung
RecordsetType | DAO.RecordsetTypeEnum (Standard: dbOpenForwardOnly)
RecordsetOptions | DAO.RecordsetOptionEnum (Standard: dbSeeChanges)
LockEdit | DAO.LockTypeEnum (Standard: dbOptimistic)
Rückgabe:
DAO.Recordset
Function OpenRecordsetPT | ( | ByVal Source As | String,
 |  | Optional ByVal RecordsetType As DAO. | RecordsetTypeEnum = dbOpenForwardOnly,
 |  | Optional ByVal RecordsetOptions As DAO. | RecordsetOptionEnum = DAO.RecordsetOptionEnum.dbSeeChanges Or DAO.RecordsetOptionEnum.dbSQLPassThrough,
 |  | Optional ByVal LockEdit As DAO. | LockTypeEnum = DAO.LockTypeEnum.dbOptimistic
 | ) |  |

OpenRecordsetPT.

Parameter:
Source | SQL-Anweisung
RecordsetType | DAO.RecordsetTypeEnum (Standard: dbOpenForwardOnly)
RecordsetOptions | DAO.RecordsetOptionEnum (Standard: dbSeeChanges+dbSQLPassThrough)
LockEdit | DAO.LockTypeEnum (Standard: dbOptimistic)
Rückgabe:
DAO.Recordset
Function RelinkPassThroughQueries | ( | Optional ByVal SavePWD As | Boolean = False,
 |  | Optional ByVal EventPeriod As | Long = 0
 | ) |  |

Alle Pass-Through-Abfragen neu verknüpfen.

Parameter:
SavePWD | ODBC-Passwort in QueryDef speichern
EventPeriod | Hilfsparamter für Wertübergabe: Anzahl der Verknüpften Elemente für DbObjectRelinked-Ereignisaufruf
Rückgabe:
Long (Anzahl der verknüpften Abfragen)
Function RelinkPassThroughQuery | ( | ByVal QueryName As | String,
 |  | Optional ByVal SavePWD As | Boolean = False
 | ) |  |

Pass-Through-Abfrage neu verknüpfen.

Parameter:
QueryName | Abfragename im Frontend
SavePWD | ODBC-Passwort in QueryDef speichern

Mit ConnectionString kann vermieden werden, dass Benutzer u. Passwort gespeichert werden.

Function RelinkTable | ( | ByVal LinkedTableName As | String,
 |  | Optional ByVal SavePWD As | Boolean = False
 | ) |  |

Verküpfte Tabelle mit möglicher Änderung der Server-Daten neu verknüpfen.

Parameter:
LinkedTableName | Tabelle im Frontend
SavePWD | ODBC-Passwort in Tabellenverknüpfung speichern
Rückgabe:
Boolean

Die TableDef-Eigenschaften SourceTableName wird nicht geändert

Function RelinkTables | ( | Optional ByVal SavePWD As | Boolean = False,
 |  | Optional ByVal EventPeriod As | Long = 0
 | ) |  |

RelinkTables.

Parameter:
SavePWD | ODBC-Passwort in Tabellenverknüpfung speichern
EventPeriod | Hilfsparamter für Wertübergabe: Anzahl der Verknüpften Elemente für DbObjectRelinked-Ereignisaufruf
Rückgabe:
Long (Anzahl der verknüpften Tabellen)
Function RelinkTablesAndQueries | ( | Optional ByVal SavePWD As | Boolean = False,
 |  | Optional ByVal EventPeriod As | Long = 0
 | ) |  |

Alle verknüpften Tabellen und Pass-Through-Abfragen neu verknüpfen.

Parameter:
SavePWD | ODBC-Passwort in Tabellenverknüpfung bzw. QueryDef speichern
EventPeriod | Hilfsparamter für Wertübergabe: Anzahl der Verknüpften Elemente für DbObjectRelinked-Ereignisaufruf
Rückgabe:
Long (Anzahl der verknüpften Tabellen und Abfragen)

Je nach Einstellung von EventPeriod wird das Ereignis DbObjectRelinked ausgelöst (0 = kein Ereignisaufruf, 1 = nach jedem Element Ereignis auslösen, 5 nach jedem 5. Element Ereignis auslösen,...).

Function Sum | ( | ByVal Expr As | String,
 |  | ByVal Domain As | String,
 |  | Optional ByVal Criteria As | Variant
 | ) |  |

DSum-Recordset-Ersatzfunktion.

Parameter:
Expr | Feldname oder berechneter Ausdruck (Select-Teil)
Domain | Tabelle, Abfrage oder SQL-Ausdruck für Sub-Abfrage (FROM-Teil)
Criteria | Filter (WHERE-Teil)
Rückgabe:
Variant
Die Dokumentation für diese Klasse wurde erzeugt aufgrund der Datei:
  • OdbcHandler.cls


DBMS Connection Wizard: WinApiShortcutMenu Klassenreferenz

  • Auflistung der Klassen
  • Klassen-Verzeichnis
  • Klassen-Elemente
Öffentliche Methoden

WinApiShortcutMenu Klassenreferenz

ShortcutMenu über Win-API. Mehr ...

Aufstellung aller Elemente

Öffentliche Methoden

Sub | AddMenuItem (ByVal lMenuItemNumber As Long, ByVal sItemText As String, Optional ByVal lItemType As MenuItemStyle=MF_STRING, Optional ByVal lSubMenu As Long=0, Optional ByVal bDefaultItem As Boolean=False)
Menü-Eintrag erstellen.
Function | OpenMenu (Optional ByVal x As Single=0, Optional ByVal y As Single=0) As Long
Öffnet das Popup-Menü

Ausführliche Beschreibung

ShortcutMenu über Win-API.

Noch zu erledigen:
Code aufräumen und Doxygen-Doku erstellen

Dokumentation der Elementfunktionen

Sub AddMenuItem | ( | ByVal lMenuItemNumber As | Long,
 |  | ByVal sItemText As | String,
 |  | Optional ByVal lItemType As | MenuItemStyle = MF_STRING,
 |  | Optional ByVal lSubMenu As | Long = 0,
 |  | Optional ByVal bDefaultItem As | Boolean = False
 | ) |  |

Menü-Eintrag erstellen.

Parameter:
lMenuItemNumber | Nummer des Menüeintrags
sItemText | Text des Menüeintrags
lItemType | Art des Menüeintrags
lSubMenu | Nummer des zugeordneten Untermenüs
Function OpenMenu | ( | Optional ByVal x As | Single = 0,
 |  | Optional ByVal y As | Single = 0
 | ) |  |

Öffnet das Popup-Menü

Parameter:
X | gewünschte X-Positon .. kann entfallen, wenn Control angegeben wurde
X | gewünschte Y-Positon .. kann entfallen, wenn Control angegeben wurde
Rückgabe:
Nummer des ausgewählten Menüeintrags
Die Dokumentation für diese Klasse wurde erzeugt aufgrund der Datei:
  • WinApiShortcutMenu.cls


DBMS Connection Wizard: Klassen-Verzeichnis

  • Auflistung der Klassen
  • Klassen-Verzeichnis
  • Klassen-Elemente

Klassen-Verzeichnis

A | D | F | O | W
A
D
DbConnectionInfo
F
OdbcHandler
AdodbHandler DaoHandler DbConnectionManager Form_frmConfig_DBMS
W
ApplicationHandler DbConnectionHandler DbmsConnectionStrings (defGlobal_DBMS)
O
WinApiShortcutMenu
A | D | F | O | W


DBMS Connection Wizard: Klassen-Elemente

  • Auflistung der Klassen
  • Klassen-Verzeichnis
  • Klassen-Elemente
  • Alle
  • Funktionen
  • Verwandte Funktionen
  • a
  • c
  • d
  • e
  • g
  • h
  • i
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
Hier folgt die Aufzählung aller dokumentierten Klassenelemente mit Verweisen auf die Klassendokumentation zu jedem Element:

- a -

  • AddMenuItem() : WinApiShortcutMenu
  • ADODB() : DbConnectionHandler
  • AppDb() : ApplicationHandler
  • ApplicationFullName() : ApplicationHandler
  • ApplicationName() : ApplicationHandler
  • ApplicationStartFormName() : ApplicationHandler

- c -

  • CallExtensionProcedure() : ApplicationHandler
  • ChangeDbUserPassword() : DbConnectionInfo
  • CheckConnection() : DbConnectionInfo
  • CheckConnectionStatus() : DbConnectionManager
  • ClearConnectionInfo() : DbConnectionInfo
  • ConnectionInfo() : DbConnectionManager
  • ConnectionString() : AdodbHandler , OdbcHandler , AdodbHandler
  • ConnectionStrings() : DbConnectionInfo
  • Count() : AdodbHandler , DaoHandler , OdbcHandler
  • CreateAppFile() : ApplicationHandler
  • CurrentConnection() : AdodbHandler , DbConnectionHandler
  • CurrentDb() : DbConnectionHandler , DaoHandler , DbConnectionHandler , OdbcHandler
  • CurrentDbBE() : DbConnectionHandler , OdbcHandler , DbConnectionHandler

- d -

  • DAO() : DbConnectionHandler
  • DbConnection() : DbConnectionManager
  • DbmsConnectionChanged() : DbConnectionInfo
  • DbmsConnectionInfoCleared() : DbConnectionInfo
  • DbmsInfoMessage() : DbConnectionInfo
  • DbObjectDeleted() : OdbcHandler
  • DbObjectRelinked() : OdbcHandler
  • DbUser() : DbConnectionInfo
  • DbUserPassword() : DbConnectionInfo
  • DeleteOdbcTableDefs() : OdbcHandler
  • Dispose() : DbConnectionHandler
  • Disposed() : DbConnectionHandler

- e -

  • ErrorEmptyConnectionString() : AdodbHandler , OdbcHandler
  • ErrorEmptyOdbcConnectionString() : DbConnectionHandler
  • ErrorEmptyOledbConnectionString() : DbConnectionHandler
  • ErrorMissingCurrentConnection() : AdodbHandler , DbConnectionHandler
  • ErrorMissingCurrentDb() : DbConnectionHandler , OdbcHandler , DaoHandler
  • Execute() : DaoHandler , AdodbHandler , OdbcHandler
  • ExecuteCommand() : AdodbHandler
  • ExecuteParamSQL() : DaoHandler
  • ExecutePT() : OdbcHandler
  • ExecuteQueryDef() : DaoHandler
  • ExecuteQueryDefByName() : DaoHandler

- g -

  • GetExtensionInstance() : ApplicationHandler

- h -

  • HookInsertIdentityReturn() : OdbcHandler

- i -

  • InsertIdentityReturn() : AdodbHandler , OdbcHandler , DaoHandler

- l -

  • LinkTable() : OdbcHandler
  • Lookup() : AdodbHandler , OdbcHandler , DaoHandler
  • LookupSQL() : AdodbHandler , OdbcHandler , DaoHandler
  • LookupSqlPT() : OdbcHandler

- m -

  • Max() : AdodbHandler , DaoHandler , OdbcHandler
  • MdiBackColor : ApplicationHandler
  • Min() : OdbcHandler , DaoHandler , AdodbHandler

- o -

  • ODBC() : DbConnectionHandler
  • OdbcConnectionString() : DbConnectionHandler , DbConnectionInfo , DbConnectionHandler
  • OledbConnectionString() : DbConnectionHandler , DbConnectionInfo
  • OpenMenu() : WinApiShortcutMenu
  • OpenRecordset() : AdodbHandler , DaoHandler , OdbcHandler
  • OpenRecordsetParamSQL() : DaoHandler
  • OpenRecordsetPT() : OdbcHandler
  • OpenRecordsetQueryDef() : DaoHandler
  • OpenRecordsetQueryDefByName() : DaoHandler

- p -

  • ParseTableName() : DbConnectionInfo
  • PermanentBackendRstSqlText() : DbConnectionInfo

- r -

  • RelinkPassThroughQueries() : OdbcHandler
  • RelinkPassThroughQuery() : OdbcHandler
  • RelinkTable() : OdbcHandler
  • RelinkTables() : OdbcHandler
  • RelinkTablesAndQueries() : OdbcHandler

- s -

  • SavePassword() : DbConnectionInfo
  • Start() : ApplicationHandler
  • Sum() : DaoHandler , AdodbHandler , OdbcHandler

- t -

  • TableListSqlText() : DbConnectionInfo

- u -

  • UseLoginForm() : DbConnectionInfo

- v -

  • Version() : ApplicationHandler


DBMS Connection Wizard: Pakete

  • Pakete
  • Paketfunktionen

Pakete

Hier folgen die Pakete mit einer Kurzbeschreibung (wenn verfügbar):
_AccessCodeLib_license | Access-codelib.net Lizenz
_config_Application | Beispiel für Anwendungskonfiguration
_initApplication | Initialisierungsaufruf der Anwendung
defGlobal | Allgemeine Konstanten und Eigenschaften
defGlobal_DBMS | Allgemeine Konstanten und Eigenschaften für DBMS-Teile
modADO | Hilfeprozeduren um das Schreiben von Code etwas abzukürzen Außerdem ist eine einfache Umstellung der verwendeten Zugriffsbibliotheken möglich
modApplication | Standard-Prozeduren für die Arbeit mit ApplicationHandler
modDAO | Zugriff auf lokale Objekte Hilfeprozeduren um das Schreiben von Code etwas abzukürzen Außerdem ist eine einfache Umstellung der verwendeten Zugriffsbibliotheken möglich
modDbConnection | Sammlung von Prozeduren für die DbConnectionManager-Klasse
modErrorHandler | Prozeduren für die Fehlerbehandlung
modFiles | Funktionen für Dateioperationen
modODBC | Hilfeprozeduren um das Schreiben von Code etwas abzukürzen Außerdem ist eine einfache Umstellung der verwendeten Zugriffsbibliotheken möglich
modSQL_Tools | SQL-Hilfsfunktionen
modWinAPI | Gebräuchliche WinAPI-Funktionen
modWinAPI_Handles | Win-API-Funktionen: Handles
modWinAPI_Layout | WinAPI-Funktionen zur Layoutgestaltung
SqlTools | SQL-Hilfsfunktionen


DBMS Connection Wizard: Paket _AccessCodeLib_license

  • Pakete
  • Paketfunktionen

Paket _AccessCodeLib_license

access-codelib.net Lizenz Mehr ...

Ausführliche Beschreibung

access-codelib.net Lizenz

---------------------------------------------------------------------------------------
access-codelib.net Lizenz
---------------------------------------------------------------------------------------

Copyright (c) 2010, access-codelib.net All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution. Neither the name of access-codelib.net nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

---------------------------------------------------------------------------------------
BSD-Lizenz im Originial: http://opensource.org/licenses/bsd-license.php
---------------------------------------------------------------------------------------

Beachten Sie auch die Nutzungsbedingungen von access-codelib.net: http://access-codelib.net/nutzungsbedingungen.html


DBMS Connection Wizard: Paket defGlobal_DBMS

  • Pakete
  • Paketfunktionen
Klassen | Aufzählungen | Funktionen

Paket defGlobal_DBMS

Allgemeine Konstanten und Eigenschaften für DBMS-Teile. Mehr ...

Klassen

struct | DbmsConnectionStrings
Type für die gleichzeitige Übergabe der Connectionsstrings. Mehr ...

Aufzählungen

enum | DbmsConnectionModes

DbmsConnectionModes.

Mehr ...

Funktionen

Property Get | DbmsConfigFormName () As String
Name des Formulars zur DBMS-Konfiguration.

Ausführliche Beschreibung

Allgemeine Konstanten und Eigenschaften für DBMS-Teile.

Dokumentation der Aufzählungstypen

enum DbmsConnectionModes

DbmsConnectionModes.

DMBS_DSNless (1) | ohne DSN
DMBS_DSN (2) | mit DSN
aDBMS_USERDEF (128) | benutzerdefinierte Connectionstrings

Dokumentation der Funktionen

Property Get defGlobal_DBMS.DbmsConfigFormName ( )

Name des Formulars zur DBMS-Konfiguration.

Rückgabe:
String

Wird aus


DBMS Connection Wizard: Paket modADO

  • Pakete
  • Paketfunktionen
Funktionen

Paket modADO

Hilfeprozeduren um das Schreiben von Code etwas abzukürzen Außerdem ist eine einfache Umstellung der verwendeten Zugriffsbibliotheken möglich. Mehr ...

Funktionen

Property Get | CurrentConnection () As ADODB.Connection
CurrentConnection = CurrentDbConnection.ADODB.CurrentConnection
Function | OpenAdoRecordset (ByVal Source As String, Optional ByVal CursorType As CursorTypeEnum=adOpenForwardOnly, Optional ByVal LockType As LockTypeEnum=adLockReadOnly, Optional ByVal CursorLocation As ADODB.CursorLocationEnum=adUseServer, Optional ByVal DisconnectedRecordset As Boolean=False) As ADODB.Recordset
OpenRecordset = CurrentDbConnection.ADODB.OpenRecordset
Function | AdoExecute (ByVal sSQL As String, Optional ByRef lRecordsAffected As Long, Optional ByVal Options As ADODB.ExecuteOptionEnum=-1) As ADODB.Recordset
Execute = CurrentDbConnection.ADODB.Execute
Function | AdoLookupSQL (ByVal sSQL As String, Optional ByVal Index As Variant=0 &, Optional ByVal ValueIfNull As Variant=Null) As Variant
DLookup-Recordset-Ersatzfunktion für Übergabe kompletter SQL-Anweisung = CurrentDbConnection.ADODB.DLookupSQL
Function | AdoLookup (ByVal Expr As String, ByVal Domain As String, Optional ByVal Criteria As String=vbNullString, Optional ByVal ValueIfNull As Variant=Null) As Variant
DLookup-Recordset-Ersatzfunktion = CurrentDbConnection.ADODB.DLookup
Function | AdoCount (ByVal Expr As String, ByVal Domain As String, Optional ByVal Criteria As String=vbNullString) As Long
DCount-Recordset-Ersatzfunktion = CurrentDbConnection.ADODB.DCount
Function | AdoInsertIdentityReturn (ByVal InsertSQL As String, Optional ByVal IdentityTable As String=vbNullString) As Variant
Insert-SQL-Anweisung ausführen und letzten Identity-Wert (Autowert) zurückgeben = CurrentDbConnection.ADODB.InsertIdentityReturn
Function | AdoInsertValuesIdentityReturn (ByVal sSource As String, ParamArray InsertFields() As Variant) As Variant
Erweiterung zu AdoInsertIdentityReturn mit Übergabe der Feldnamen und Werte als ParamArray.

Ausführliche Beschreibung

Hilfeprozeduren um das Schreiben von Code etwas abzukürzen Außerdem ist eine einfache Umstellung der verwendeten Zugriffsbibliotheken möglich.

Autor:
Josef Pötzl

Dokumentation der Funktionen

Function modADO.AdoCount | ( | ByVal Expr As | String,
 |  | ByVal Domain As | String,
 |  | Optional ByVal Criteria As | String = vbNullString
 | ) |  |

DCount-Recordset-Ersatzfunktion = CurrentDbConnection.ADODB.DCount

Parameter:
Expr | Feldname oder berechneter Ausdruck (Select-Teil)
Domain | Tabelle, Abfrage oder SQL-Ausdruck für Sub-Abfrage (FROM-Teil)
Criteria | Filter (WHERE-Teil)
Rückgabe:
Long

gibt -1 bei Fehler zurück

Function modADO.AdoExecute | ( | ByVal sSQL As | String,
 |  | Optional ByRef lRecordsAffected As | Long,
 |  | Optional ByVal Options As ADODB. | ExecuteOptionEnum = -1
 | ) |  |

Execute = CurrentDbConnection.ADODB.Execute

Parameter:
CommandText
RecordsAffected
Options
Rückgabe:
ADODB.Recordset
Function modADO.AdoInsertIdentityReturn | ( | ByVal InsertSQL As | String,
 |  | Optional ByVal IdentityTable As | String = vbNullString
 | ) |  |

Insert-SQL-Anweisung ausführen und letzten Identity-Wert (Autowert) zurückgeben = CurrentDbConnection.ADODB.InsertIdentityReturn

Parameter:
InsertSQL Insert-SQL-Anweisung (INSERT ...)
Rückgabe:
Identity-Wert oder NULL falls kein Datensatz angefügt wurde

Funktioniert für Jet erst ab Jet 4.0 (Access 2000)

Function modADO.AdoInsertValuesIdentityReturn | ( | ByVal sSource As | String,
 |  | ParamArray InsertFields() As | Variant
 | ) |  |

Erweiterung zu AdoInsertIdentityReturn mit Übergabe der Feldnamen und Werte als ParamArray.

Parameter:
sSource | Tabellenname
InsertFields | Abwechselnd Feldname und Wert
Rückgabe:
Identity-Wert oder NULL falls kein Datensatz angefügt wurde

Beispiel: AdoInsertValuesIdentityReturn("Tabellenname", "Feld1", "123", "Feld2", "'abc'") daraus entsteht: AdoInsertIdentityReturn("Insert into Tabellenname (Feld1, Feld2) Values (123, 'abc')", "Tabellenname") (=> Übergabe der Parameterwerte als String erforderlich)

Function modADO.AdoLookup | ( | ByVal Expr As | String,
 |  | ByVal Domain As | String,
 |  | Optional ByVal Criteria As | String = vbNullString,
 |  | Optional ByVal ValueIfNull As | Variant = Null
 | ) |  |

DLookup-Recordset-Ersatzfunktion = CurrentDbConnection.ADODB.DLookup

Parameter:
Expr | Feldname oder berechneter Ausdruck (Select-Teil)
Domain | Tabelle, Abfrage oder SQL-Ausdruck für Sub-Abfrage (FROM-Teil)
Criteria | Filter (WHERE-Teil)
Rückgabe:
Variant

gibt NULL bei Fehler zurück

Function modADO.AdoLookupSQL | ( | ByVal sSQL As | String,
 |  | Optional ByVal Index As | Variant = 0 &,
 |  | Optional ByVal ValueIfNull As | Variant = Null
 | ) |  |

DLookup-Recordset-Ersatzfunktion für Übergabe kompletter SQL-Anweisung = CurrentDbConnection.ADODB.DLookupSQL

Parameter:
sSQL | SQL-Anweisung
Index | Feldauswahl, falls nicht das erste Feld des Recordsets zurückgeliefert werden soll
Rückgabe:
Variant

gibt NULL bei Fehler zurück

Property Get modADO.CurrentConnection ( )

CurrentConnection = CurrentDbConnection.ADODB.CurrentConnection

Rückgabe:
ADODB.Connection

Abkürzumg für CurrentDbConnection.ADODB.CurrentConnection

Function modADO.OpenAdoRecordset | ( | ByVal Source As | String,
 |  | Optional ByVal CursorType As | CursorTypeEnum = adOpenForwardOnly,
 |  | Optional ByVal LockType As | LockTypeEnum = adLockReadOnly,
 |  | Optional ByVal CursorLocation As ADODB. | CursorLocationEnum = adUseServer,
 |  | Optional ByVal DisconnectedRecordset As | Boolean = False
 | ) |  |

OpenRecordset = CurrentDbConnection.ADODB.OpenRecordset

Parameter:
Source | Datenquelle (SQL-Anweisung)
CursorType | ADODB.CursorTypeEnum-Wert
LockType | ADODB.LockTypeEnum-Wert
CursorLocation | ADODB.CursorLocationEnum-Wert
DisconnectedRecordset | True: Verbindung nach Öffnen des Recordset kappen ... verbindungsloses Recordset
Rückgabe:
ADODB.Recordset


DBMS Connection Wizard: Paket modDAO

  • Pakete
  • Paketfunktionen
Funktionen

Paket modDAO

Zugriff auf lokale Objekte Hilfeprozeduren um das Schreiben von Code etwas abzukürzen Außerdem ist eine einfache Umstellung der verwendeten Zugriffsbibliotheken möglich. Mehr ...

Funktionen

Property Get | CurrentDbC () As DAO.Database
CurrentDbC = CurrentDbConnection.CurrentDb = CurrentDbConnection.DAO.CurrentDb
Function | OpenDaoRecordset (ByVal Source As String, Optional ByVal RstType As DAO.RecordsetTypeEnum=dbOpenDynaset, Optional ByVal RstOptions As DAO.RecordsetOptionEnum, Optional ByVal LockEdit As DAO.LockTypeEnum=dbOptimistic) As DAO.Recordset
OpenDaoRecordset = CurrentDbConnection.DAO.OpenRecordset
Function | DaoExecute (ByVal sSQL As String, Optional ByVal Options As DAO.RecordsetOptionEnum) As Long
DaoExecute = CurrentDbConnection.DAO.Execute
Function | DaoLookupSQL (ByVal sSQL As String, Optional ByVal Index As Variant=0 &, Optional ByVal ValueIfNull As Variant=Null) As Variant
DaoLookupSQL = CurrentDbConnection.DAO.DLookupSQL
Function | DaoCount (ByVal Expr As String, ByVal Domain As String, Optional ByVal Criteria As String=vbNullString) As Long
DaoCount = CurrentDbConnection.DAO.DCount
Function | DaoInsertIdentityReturn (ByVal InsertSQL As String) As Variant
DaoInsertIdentityReturn = CurrentDbConnection.DAO.InsertIdentityReturn
Function | DeleteTableDef (ByVal sTabName As String) As Boolean
Tabelle im Frontend löschen.

Ausführliche Beschreibung

Zugriff auf lokale Objekte Hilfeprozeduren um das Schreiben von Code etwas abzukürzen Außerdem ist eine einfache Umstellung der verwendeten Zugriffsbibliotheken möglich.

Der eigentliche Zugriff erfolgt über CurrentDbConnection

Dokumentation der Funktionen

Property Get modDAO.CurrentDbC ( )

CurrentDbC = CurrentDbConnection.CurrentDb = CurrentDbConnection.DAO.CurrentDb

Rückgabe:
DAO.Database
Function modDAO.DaoCount | ( | ByVal Expr As | String,
 |  | ByVal Domain As | String,
 |  | Optional ByVal Criteria As | String = vbNullString
 | ) |  |

DaoCount = CurrentDbConnection.DAO.DCount

Parameter:
Expr | Feldname oder "*"
Domain | Datenquelle
Criteria | Filterausdruck
Function modDAO.DaoExecute | ( | ByVal sSQL As | String,
 |  | Optional ByVal Options As DAO. | RecordsetOptionEnum
 | ) |  |

DaoExecute = CurrentDbConnection.DAO.Execute

Parameter:
sSQL | SQL-Anweisung
[out] | RecordsAffected | Anzahl der betroffenen Datensätzen
Options | Optionen für Execute (analog DAO.Database.Execute)
Function modDAO.DaoInsertIdentityReturn ( ByVal InsertSQL As String )

DaoInsertIdentityReturn = CurrentDbConnection.DAO.InsertIdentityReturn

Parameter:
InsertSQL Insert-SQL-Anweisung
Function modDAO.DaoLookupSQL | ( | ByVal sSQL As | String,
 |  | Optional ByVal Index As | Variant = 0 &,
 |  | Optional ByVal ValueIfNull As | Variant = Null
 | ) |  |

DaoLookupSQL = CurrentDbConnection.DAO.DLookupSQL

Parameter:
sSQL SQL-Anweisung
Function modDAO.DeleteTableDef ( ByVal sTabName As String )

Tabelle im Frontend löschen.

Parameter:
sTabName Tabellen-Name
Rückgabe:
Boolean
Function modDAO.OpenDaoRecordset | ( | ByVal Source As | String,
 |  | Optional ByVal RstType As DAO. | RecordsetTypeEnum = dbOpenDynaset,
 |  | Optional ByVal RstOptions As DAO. | RecordsetOptionEnum,
 |  | Optional ByVal LockEdit As DAO. | LockTypeEnum = dbOptimistic
 | ) |  |

OpenDaoRecordset = CurrentDbConnection.DAO.OpenRecordset

Parameter:
Source | SQL-Anweisung
RecordsetType | DAO.RecordsetTypeEnum (Standard: dbOpenDynaset)
RecordsetOptions | DAO.RecordsetOptionEnum (Standard: dbSeeChanges)
LockEdit | DAO.LockTypeEnum (Standard: dbOptimistic)
Rückgabe:
DAO.Recordset


DBMS Connection Wizard: Paket modDbConnection

  • Pakete
  • Paketfunktionen
Funktionen

Paket modDbConnection

Sammlung von Prozeduren für die DbConnectionManager-Klasse. Mehr ...

Funktionen

Property Get | CurrentDbConnection () As DbConnectionHandler
Zugriff auf DbConnection der Haupt-DbConnectionManager-Instanz.
Property Get | CurrentConnectionInfo () As DbConnectionInfo
Zugriff auf DbConnectionInfo der Haupt-DbConnectionManager-Instanz.
Function | CheckConnectionStatus () As Boolean
Verbindung prüfen DbConnectionManager.CheckConnectionStatus

Ausführliche Beschreibung

Sammlung von Prozeduren für die DbConnectionManager-Klasse.

Dient zum Instanzieren von DbConnectionManager und für den Zugriff auf die Hauptelemente von DbConnectionManager

Dokumentation der Funktionen

Function modDbConnection.CheckConnectionStatus ( )

Verbindung prüfen DbConnectionManager.CheckConnectionStatus

Rückgabe:
Boolean: True = Verbindungsaufbau war erfolgreich
Property Get modDbConnection.CurrentConnectionInfo ( )

Zugriff auf DbConnectionInfo der Haupt-DbConnectionManager-Instanz.

Rückgabe:
DbConnectionInfo

Erleichtert den Aufruf, da das Schreiben der DbConnectionManager-Instanz-Variablen entfällt. Beim ersten Zugriff wird die Instanz der DbConnectionManager-Klasse erstellt, falls diese noch nicht vorhanden ist.

Property Get modDbConnection.CurrentDbConnection ( )

Zugriff auf DbConnection der Haupt-DbConnectionManager-Instanz.

Rückgabe:
DbConnectionHandler

Erleichtert den Aufruf, da das Schreiben der DbConnectionManager-Instanz-Variablen entfällt. Beim ersten Zugriff wird die Instanz der DbConnectionManager-Klasse erstellt, falls diese noch nicht vorhanden ist.


DBMS Connection Wizard: Paket modFiles

  • Pakete
  • Paketfunktionen
Funktionen

Paket modFiles

Funktionen für Dateioperationen. Mehr ...

Funktionen

Function | SelectFile (Optional ByVal InitialDir As String=vbNullString, Optional ByVal DlgTitle As String=m_SELECTBOX_File_DlgTitle, Optional ByVal FilterString As String="Alle Dateien (*.*)", Optional ByVal MultiSelectEnabled As Boolean=False, Optional ByVal ViewMode As Long=-1) As String
Datei mittels Dialog auswählen.
Function | SelectFolder (Optional ByVal InitialDir As String=vbNullString, Optional ByVal DlgTitle As String=m_SELECTBOX_Folder_DlgTitle, Optional ByVal FilterString As String="*", Optional ByVal MultiSelectEnabled As Boolean=False, Optional ByVal ViewMode As Long=-1) As String
Auswahldialog zur Verzeichnisauswahl.
Property Get | TempPath () As String
Temp-Verzeichnis ermitteln.
Function | ShortFileName (ByVal vFile As Variant, Optional ByVal lMaxLen As Long=40) As String
Dateipfad auf n Zeichen kürzen.
Function | FileNameWithoutPath (ByVal vFile As Variant) As String
Dateinamen ohne Verzeichnis.
Function | CreateDirectory (ByVal sPath As String) As Boolean
Erstelle ein Verzeichnis inkl. aller fehlenden übergeordneten Verzeichnisse.
Function | FileExists (ByVal PathName As String) As Boolean
Prüft Existens einer Datei.
Function | DirExists (ByVal PathName As String) As Boolean
Prüft Existenz eines Verzeichnisses.
Function | GetFileUpdateDate (ByVal FullFileName As String) As Variant
Letztes Änderungsdatum einer Datei.
Function | GetClearedStringForFileName (ByVal strName As String, Optional ByVal ReplacementSign As String="_") As String
Erzeugt aus einer Zeichenkette einen Dateinamen (ersetzt Sonderzeichen)
Function | GetFullPathFromRelativPath (ByVal sRelativPath As String, ByVal sBaseFolder As String) As String
Erezugt aus relativer Pfadangabe und "Basisverzeichnis" eine vollständige Pfadangabe.
Function | GetRelativPathFromFullPath (ByVal sFullPath As String, ByVal sBaseFolder As String, Optional ByVal EnableRelativePrefix As Boolean=False) As String
Erzeugt einen relativen Pfad aus vollständiger Pfadangabe und Ausgangsverzeichnis.
Function | GetDirFromFilePath (ByVal sFileName As String) As String
Ermittels aus vollständer Pfadangabe einer Datei das Verzeichnis.
Sub | AddToZipFile (ByVal zipFile As String, ByVal sFile As String)
Datei an Zip-Datei anhängen.

Ausführliche Beschreibung

Funktionen für Dateioperationen.

Dokumentation der Funktionen

Sub modFiles.AddToZipFile | ( | ByVal zipFile As | String,
 |  | ByVal sFile As | String
 | ) |  |

Datei an Zip-Datei anhängen.

Parameter:
Param
Rückgabe:

CreateObject("Shell.Application").Namespace(zipFile & "").CopyHere sFile & ""

Function modFiles.CreateDirectory ( ByVal sPath As String )

Erstelle ein Verzeichnis inkl. aller fehlenden übergeordneten Verzeichnisse.

Parameter:
spath Zu erstellendes Verzeichnis
Rückgabe:
Boolean: True = Verzeichnis wurde erstellt
Function modFiles.DirExists ( ByVal PathName As String )

Prüft Existenz eines Verzeichnisses.

Parameter:
PathName Vollständige Pfadangabe
Rückgabe:
Boolean
Function modFiles.FileExists ( ByVal PathName As String )

Prüft Existens einer Datei.

Parameter:
PathName Vollständige Pfadangabe
Rückgabe:
Boolean
Function modFiles.FileNameWithoutPath ( ByVal vFile As Variant )

Dateinamen ohne Verzeichnis.

Parameter:
vFile Dateiname inkl. Verzeichnis
Rückgabe:
String
Function modFiles.GetClearedStringForFileName | ( | ByVal strName As | String,
 |  | Optional ByVal ReplacementSign As | String = "_"
 | ) |  |

Erzeugt aus einer Zeichenkette einen Dateinamen (ersetzt Sonderzeichen)

Parameter:
strName | Ausgangsstring für Dateinamen
ReplacementSign | Zeichen als Ersatz für Sonderzeichen
Rückgabe:
String

Sonderzeichen: ? * " / ' : ( )

Function modFiles.GetDirFromFilePath ( ByVal sFileName As String )

Ermittels aus vollständer Pfadangabe einer Datei das Verzeichnis.

Parameter:
sFileName vollständer Pfadangabe
Rückgabe:
String
Function modFiles.GetFileUpdateDate ( ByVal FullFileName As String )

Letztes Änderungsdatum einer Datei.

Parameter:
FullFileName Vollständige Pfadangabe
Rückgabe:
Variant
Function modFiles.GetFullPathFromRelativPath | ( | ByVal sRelativPath As | String,
 |  | ByVal sBaseFolder As | String
 | ) |  |

Erezugt aus relativer Pfadangabe und "Basisverzeichnis" eine vollständige Pfadangabe.

Parameter:
sRelativPath | relativer Pfad
sBaseFolder | Ausgangsverzeichnis
Rückgabe:
String

Beispiel: GetFullPathFromRelativPath("..\..\Test.txt", "C:\Programme\xxx\") => "C:\test.txt"

Function modFiles.GetRelativPathFromFullPath | ( | ByVal sFullPath As | String,
 |  | ByVal sBaseFolder As | String,
 |  | Optional ByVal EnableRelativePrefix As | Boolean = False
 | ) |  |

Erzeugt einen relativen Pfad aus vollständiger Pfadangabe und Ausgangsverzeichnis.

Parameter:
sFullPath | vollständiger Pfadangabe
sBaseFolder | Ausgangsverzeichnis
RelativePrefix | ".\" als Kennung für relativen Pfad ergänzen
Rückgabe:
String

Beispiel: GetRelativPathFromFullPath("C:\test.txt", "C:\Programme\xxx\", True) => ".\..\..\test.txt"

Function modFiles.SelectFile | ( | Optional ByVal InitialDir As | String = vbNullString,
 |  | Optional ByVal DlgTitle As | String = m_SELECTBOX_File_DlgTitle,
 |  | Optional ByVal FilterString As | String = "Alle Dateien (*.*)",
 |  | Optional ByVal MultiSelectEnabled As | Boolean = False,
 |  | Optional ByVal ViewMode As | Long = -1
 | ) |  |

Datei mittels Dialog auswählen.

Parameter:
InitDir | Startverzeichnis
DlgTitle | Dialogtitel
FilterString | Filterwerten - Beispiel: "(*.*)" oder "Alle (*.*)|Textdateien (*.txt)|Bilder (*.png;*.jpg;*.gif)</param> <param name="MultiSelect">Mehrfachauswahl</param> <param name="viewMode">Anzeigeart (0: Detailansicht, 1: Vorschauansicht, 2: Eigenschaften, 3: Liste, 4: Miniaturansicht, 5: Große Symbole, 6: Kleine Symbole)
Rückgabe:
String (bei Mehfachauswahl sind die Dateien durch chr(9) getrennt)
Function modFiles.SelectFolder | ( | Optional ByVal InitialDir As | String = vbNullString,
 |  | Optional ByVal DlgTitle As | String = m_SELECTBOX_Folder_DlgTitle,
 |  | Optional ByVal FilterString As | String = "*",
 |  | Optional ByVal MultiSelectEnabled As | Boolean = False,
 |  | Optional ByVal ViewMode As | Long = -1
 | ) |  |

Auswahldialog zur Verzeichnisauswahl.

Parameter:
InitDir | Startverzeichnis
DlgTitle | Dialogtitel
FilterString | Filterwerten - Beispiel: "(*.*)" oder "Alle (*.*)|Textdateien (*.txt)|Bilder (*.png;*.jpg;*.gif)</param> <param name="MultiSelect">Mehrfachauswahl</param> <param name="viewMode">Anzeigeart (0: Detailansicht, 1: Vorschauansicht, 2: Eigenschaften, 3: Liste, 4: Miniaturansicht, 5: Große Symbole, 6: Kleine Symbole)
Rückgabe:
String (bei Mehfachauswahl sind die Dateien durch chr(9) getrennt)
Function modFiles.ShortFileName | ( | ByVal vFile As | Variant,
 |  | Optional ByVal lMaxLen As | Long = 40
 | ) |  |

Dateipfad auf n Zeichen kürzen.

Parameter:
vFile | Vollständiger Pfad
lMaxLen | die gewünschte Länge
Rückgabe:
String

Hilfreich für die Anzeigen in schmalen Textfeldern
Beispiel: <source>C:\....txt</source>

Property Get modFiles.TempPath ( )

Temp-Verzeichnis ermitteln.

Parameter:
Param
Rückgabe:
String

Verwendet API GetTempPathA


DBMS Connection Wizard: Paket modODBC

  • Pakete
  • Paketfunktionen
Funktionen

Paket modODBC

Hilfeprozeduren um das Schreiben von Code etwas abzukürzen Außerdem ist eine einfache Umstellung der verwendeten Zugriffsbibliotheken möglich. Mehr ...

Funktionen

Property Get | CurrentDbBE () As DAO.Database
CurrentDbBE = CurrentDbConnection.ODBC.CurrentDbBE
Function | OpenRecordsetDaoBE (ByVal Quelle As String, Optional ByVal RstType As RecordsetTypeEnum=dbOpenDynaset, Optional ByVal RstOptions As RecordsetOptionEnum) As DAO.Recordset
OpenRecordsetDaoBE = CurrentDbConnection.ODBC.OpenRecordset
Function | OpenRecordsetPT (ByVal sSQL As String, Optional ByVal RstType As RecordsetTypeEnum=dbOpenDynaset, Optional ByVal RstOptions As RecordsetOptionEnum, Optional ByVal RstLockEdit As Long=dbReadOnly) As DAO.Recordset
OpenRecordsetPT = CurrentDbConnection.ODBC.OpenRecordsetPT
Function | OdbcExecutePT (ByVal sSQL As String, Optional ByVal RstOptions As DAO.RecordsetOptionEnum) As Long
OdbcExecutePT = CurrentDbConnection.ODBC.OdbcExecutePT
Sub | LinkTable (ByVal SourceTableName As String, Optional ByVal sLinkedTableName As String=vbNullString, Optional ByVal bRemoveSchemaName As Boolean=True)
LinkTable = CurrentDbConnection.ODBC.LinkTable
Function | ReconnectODBC (Optional ByVal lEventCounter As Long=0) As Boolean
ReconnectODBC verwendet CurrentDbConnection.ODBC.RelinkTablesAndQueries
Function | DeleteOdbcTableDefs (Optional ByVal lEventCounter As Long=0) As Boolean
DeleteOdbcTableDefs verwendet CurrentDbConnection.ODBC.DeleteOdbcTableDefs

Ausführliche Beschreibung

Hilfeprozeduren um das Schreiben von Code etwas abzukürzen Außerdem ist eine einfache Umstellung der verwendeten Zugriffsbibliotheken möglich.

Dokumentation der Funktionen

Function modODBC.DeleteOdbcTableDefs ( Optional ByVal lEventCounter As Long = 0 )

DeleteOdbcTableDefs verwendet CurrentDbConnection.ODBC.DeleteOdbcTableDefs

Parameter:
lEventCounter Anzahl der gelöschen Elemente nach der das Info-Ereignis OdbcHandler.DbObjectDeleted ausgelöst werden soll
Rückgabe:
Boolean: True = Löschen abgeschlossen
Function modODBC.OdbcExecutePT | ( | ByVal sSQL As | String,
 |  | Optional ByVal RstOptions As DAO. | RecordsetOptionEnum
 | ) |  |

OdbcExecutePT = CurrentDbConnection.ODBC.OdbcExecutePT

Parameter:
sSQL | SQL-Anweisung
RstOptions | RecordsetOptionEnum analog DAO-Execute
Function modODBC.ReconnectODBC ( Optional ByVal lEventCounter As Long = 0 )

ReconnectODBC verwendet CurrentDbConnection.ODBC.RelinkTablesAndQueries

Parameter:
lEventCounter Anzahl der verknüpften Elemente nach der das Info-Ereignis OdbcHandler.DbObjectRelinked ausgelöst werden soll
Rückgabe:
Boolean: True = Verknüpfung abgeschlossen


DBMS Connection Wizard: Paket modSQL_Tools

  • Pakete
  • Paketfunktionen
Funktionen

Paket modSQL_Tools

SQL-Hilfsfunktionen. Mehr ...

Funktionen

Function | GetSQLString_Text (ByVal vValue As Variant, Optional ByVal sDelimiter As String=SQL_DEFAULT_TEXTDELIMITER, Optional ByVal bWithoutLeftRightDelim As Boolean=False) As String
Text für SQL-Anweisung aufbereiten.
Function | GetSQLString_Date (ByVal vValue As Variant, Optional sFormatString As String=SQL_DEFAULT_DATEFORMAT) As String
Datumswert in String für SQL-Anweisung umwandeln, die per VBA zusammengesetzt wird.
Function | GetSQLString_Number (ByVal vValue As Variant) As String
Zahl für SQL-Text aufbereiten.

Ausführliche Beschreibung

SQL-Hilfsfunktionen.

Autor:
Josef Pötzl
Warnung:
Nicht vergessen: SQL_DEFAULT_TEXTDELIMITER und SQL_DEFAULT_DATEFORMAT für das DBMS anpassen oder die Parameter entsprechend einstellen.

Dokumentation der Funktionen

Function modSQL_Tools.GetSQLString_Date | ( | ByVal vValue As | Variant,
 |  | Optional sFormatString As | String = SQL_DEFAULT_DATEFORMAT
 | ) |  |

Datumswert in String für SQL-Anweisung umwandeln, die per VBA zusammengesetzt wird.

Parameter:
vValue | Übergabewert
sFormatString | Datumsformat (von DBMS abhängig!)
Rückgabe:
String
Function modSQL_Tools.GetSQLString_Number ( ByVal vValue As Variant )

Zahl für SQL-Text aufbereiten.

Parameter:
vValue Übergabewert
Rückgabe:
String

Durch Str-Funktion wird . statt , verwendet.

Function modSQL_Tools.GetSQLString_Text | ( | ByVal vValue As | Variant,
 |  | Optional ByVal sDelimiter As | String = SQL_DEFAULT_TEXTDELIMITER,
 |  | Optional ByVal bWithoutLeftRightDelim As | Boolean = False
 | ) |  |

Text für SQL-Anweisung aufbereiten.

Parameter:
vValue | Übergabewert
sDelimiter | Begrenzungszeichen für Text-Werte. (In den meinsten DBMS wird ' als Begrenzungszeichen verwendet.)
bWithoutLeftRightDelim | Nur Begrenzungszeichnen innerhalb des Werte verdoppeln, Eingrenzung jedoch nicht setzen.
Rückgabe:
String

Beispiel: strSQL = "select ... from tabelle where Feld = " & GetSQLString_Text("ab'cd") => strSQL = "select ... from tabelle where Feld = 'ab''cd'"


DBMS Connection Wizard: Paket modWinAPI

  • Pakete
  • Paketfunktionen
Funktionen

Paket modWinAPI

Gebräuchliche WinAPI-Funktionen. Mehr ...

Funktionen

Function | ShellExecuteOpenFile (ByVal sFile As String, Optional ByVal sAPIOperation As String=vbNullString) As Boolean
Datei mit ShellExecute öffnen.
Function | ShellExecuteSendMail (ByVal sTo As String, ByVal sSubject As String, ByVal sBody As String) As Boolean
Email mit Standard-Programm versenden.
Function | LaunchAppSynchronous (ByVal strExecutablePathAndName As String, Optional ByVal sParam As String=vbNullString, Optional ByVal lShowCommand As Long=vbNormalFocus) As Boolean
Anwnedung Synchron ausführen.
Sub | SetFormIconFromFile (ByRef formRef As Access.Form, ByVal IconFilePath As String)
Spezielles Icon für ein Formular einstellen.

Ausführliche Beschreibung

Gebräuchliche WinAPI-Funktionen.

Sammlung von API-Deklarationen, die oft benötigt werden

Dokumentation der Funktionen

Function modWinAPI.LaunchAppSynchronous | ( | ByVal strExecutablePathAndName As | String,
 |  | Optional ByVal sParam As | String = vbNullString,
 |  | Optional ByVal lShowCommand As | Long = vbNormalFocus
 | ) |  |

Anwnedung Synchron ausführen.

Parameter:
strExecutablePathAndName | Ausführbare Datei
sParam | Startparameter der Anwendung
lShowCommand | Fenstermodus
Rückgabe:
Boolean

Code hält so lange an, bis die gestartete Anwendung beendet wurde.

Sub modWinAPI.SetFormIconFromFile | ( | ByRef formRef As Access. | Form,
 |  | ByVal IconFilePath As | String
 | ) |  |

Spezielles Icon für ein Formular einstellen.

Parameter:
FormRef | Referenz zum Access.Form
IconFilePath | Icon-Datei (vollständige Pfadangabe)
Function modWinAPI.ShellExecuteOpenFile | ( | ByVal sFile As | String,
 |  | Optional ByVal sAPIOperation As | String = vbNullString
 | ) |  |

Datei mit ShellExecute öffnen.

Parameter:
sFile | vollständiger Dateiname inkl. Verzeichnis
sAPIOperation | "open", "print", ...
Rückgabe:
Boolean
Function modWinAPI.ShellExecuteSendMail | ( | ByVal sTo As | String,
 |  | ByVal sSubject As | String,
 |  | ByVal sBody As | String
 | ) |  |

Email mit Standard-Programm versenden.

Parameter:
sTo | Empfänger-Adresse
sSubject | Betreff-Zeile
sBody | Email-Text
Rückgabe:
Boolean


DBMS Connection Wizard: Paket modWinAPI_Handles

  • Pakete
  • Paketfunktionen
Funktionen

Paket modWinAPI_Handles

Win-API-Funktionen: Handles. Mehr ...

Funktionen

Function | GetMDI () As Long
Ermittelt den Handle des MDI-Client-Fensters.
Function | GetHeaderSection (ByVal fHwnd As Long) As Long
Ermittelt den Handle für den Kopfbereich eines Formulares.
Function | GetDetailSection (ByVal fHwnd As Long) As Long
Ermittelt den Handle für den Detailbereich eines Formulares.
Function | GetFooterSection (ByVal fHwnd As Long) As Long
Ermittelt den Handle für den Fußbereich eines Formulares.
Function | GetControl (ByRef frm As Access.Form, ByVal sHwnd As Long, ByVal sClassName As String, ByVal ControlName As String) As Long
Ermittelt den Handle eines beliebigen Controls.

Ausführliche Beschreibung

Win-API-Funktionen: Handles.

Dokumentation der Funktionen

Function modWinAPI_Handles.GetControl | ( | ByRef frm As Access. | Form,
 |  | ByVal sHwnd As | Long,
 |  | ByVal sClassName As | String,
 |  | ByVal ControlName As | String
 | ) |  |

Ermittelt den Handle eines beliebigen Controls.

Parameter:
frm | Formular-Referenz
sHwnd | Handle des Bereichs, auf dem sich das Control befindet (Header, Detail, Footer)
ClassName | Name der Fensterklasse des Controls
ControlName | Name des Controls
Rückgabe:
Long
Function modWinAPI_Handles.GetDetailSection ( ByVal fHwnd As Long )

Ermittelt den Handle für den Detailbereich eines Formulares.

Parameter:
fHwnd Handle des Formulars (Form.Hwnd)
Rückgabe:
Long
Function modWinAPI_Handles.GetFooterSection ( ByVal fHwnd As Long )

Ermittelt den Handle für den Fußbereich eines Formulares.

Parameter:
fHwnd Handle des Formulars (Form.Hwnd)
Rückgabe:
Long
Function modWinAPI_Handles.GetHeaderSection ( ByVal fHwnd As Long )

Ermittelt den Handle für den Kopfbereich eines Formulares.

Parameter:
fHwnd Handle des Formulars (Form.Hwnd)
Rückgabe:
Long
Function modWinAPI_Handles.GetMDI ( )

Ermittelt den Handle des MDI-Client-Fensters.

Rückgabe:
Handle (Long)


DBMS Connection Wizard: Paket modWinAPI_Layout

  • Pakete
  • Paketfunktionen
Funktionen

Paket modWinAPI_Layout

WinAPI-Funktionen zur Layoutgestaltung. Mehr ...

Funktionen

Sub | SetBackColor (ByVal Hwnd As Long, ByVal Color As Long)
Hintergrundfarbe eines Fensters einstellen.
Function | TwipsPerPixelX () As Single
Breite eines Pixels in twips.
Function | TwipsPerPixelY () As Single
Höhe eines Pixels in twips.
Function | GetScrollbarWidth () As Single
Breite der Bildlaufleiste.
Function | GetTwipsFromPixel (ByVal pixel As Long) As Long
Rechnet Pixel in Twips um.
Function | GetPixelFromTwips (ByVal twips As Long) As Long
Rechnet twips in Pixel um.

Ausführliche Beschreibung

WinAPI-Funktionen zur Layoutgestaltung.

Dokumentation der Funktionen

Function modWinAPI_Layout.GetPixelFromTwips ( ByVal twips As Long )

Rechnet twips in Pixel um.

Parameter:
twips Anzahl twips
Rückgabe:
Long

GetPixelFromTwips = twips / TwipsPerPixelX

Function modWinAPI_Layout.GetScrollbarWidth ( )

Breite der Bildlaufleiste.

Parameter:
Param
Rückgabe:
Single
Function modWinAPI_Layout.GetTwipsFromPixel ( ByVal pixel As Long )

Rechnet Pixel in Twips um.

Parameter:
pixel Anzahl der Pixel
Rückgabe:
Long

GetTwipsFromPixel = TwipsPerPixelX * pixel

Sub modWinAPI_Layout.SetBackColor | ( | ByVal Hwnd As | Long,
 |  | ByVal Color As | Long
 | ) |  |

Hintergrundfarbe eines Fensters einstellen.

Parameter:
Hwnd | Fenster-Handle
Color | Farbnummer
Rückgabe:
Function modWinAPI_Layout.TwipsPerPixelX ( )

Breite eines Pixels in twips.

Parameter:
Param
Rückgabe:
Single

http://support.microsoft.com/kb/94927/de

Function modWinAPI_Layout.TwipsPerPixelY ( )

Höhe eines Pixels in twips.

Rückgabe:
Single

http://support.microsoft.com/kb/94927/de


DBMS Connection Wizard: Paket SqlTools

  • Pakete
  • Paketfunktionen
Funktionen

Paket SqlTools

SQL-Hilfsfunktionen. Mehr ...

Funktionen

Function | TextToSqlText (ByVal Value As Variant, Optional ByVal Delimiter As String=SQL_DEFAULT_TEXTDELIMITER, Optional ByVal WithoutLeftRightDelim As Boolean=False) As String
Text für SQL-Anweisung aufbereiten.
Function | DateToSqlText (ByVal Value As Variant, Optional ByVal FormatString As String=SQL_DEFAULT_DATEFORMAT) As String
Datumswert in String für SQL-Anweisung umwandeln, die per VBA zusammengesetzt wird.
Function | NumberToSqlText (ByVal Value As Variant) As String
Zahl für SQL-Text aufbereiten.

Ausführliche Beschreibung

SQL-Hilfsfunktionen.

Autor:
Josef Poetzl
Warnung:
Nicht vergessen: SQL_DEFAULT_TEXTDELIMITER und SQL_DEFAULT_DATEFORMAT für das DBMS anpassen oder die Parameter entsprechend einstellen.

Dokumentation der Funktionen

Function SqlTools.DateToSqlText | ( | ByVal Value As | Variant,
 |  | Optional ByVal FormatString As | String = SQL_DEFAULT_DATEFORMAT
 | ) |  |

Datumswert in String für SQL-Anweisung umwandeln, die per VBA zusammengesetzt wird.

Parameter:
vValue | Übergabewert
sFormatString | Datumsformat (von DBMS abhängig!)
ValueIfNull | Ersatzstring bei NULL (Standard = "NULL")
Rückgabe:
String
Function SqlTools.NumberToSqlText ( ByVal Value As Variant )

Zahl für SQL-Text aufbereiten.

Parameter:
Value | Übergabewert
ValueIfNull | Ersatzstring bei NULL (Standard = "NULL")
Rückgabe:
String

Durch Str-Funktion wird . statt , verwendet.

Function SqlTools.TextToSqlText | ( | ByVal Value As | Variant,
 |  | Optional ByVal Delimiter As | String = SQL_DEFAULT_TEXTDELIMITER,
 |  | Optional ByVal WithoutLeftRightDelim As | Boolean = False
 | ) |  |

Text für SQL-Anweisung aufbereiten.

Parameter:
Value | Übergabewert
Delimiter | Begrenzungszeichen für Text-Werte. (In den meisten DBMS wird ' als Begrenzungszeichen verwendet.)
WithoutLeftRightDelim | Nur Begrenzungszeichnen innerhalb des Werte verdoppeln, Eingrenzung jedoch nicht setzen.
ValueIfNull | Ersatzstring bei NULL (Standard = "NULL")
Rückgabe:
String

Beispiel: strSQL = "select ... from tabelle where Feld = " & TextToSqlText("ab'cd") => strSQL = "select ... from tabelle where Feld = 'ab''cd'"


DBMS Connection Wizard: Paketfunktionen

  • Pakete
  • Paketfunktionen
  • Alle
  • Funktionen
  • Aufzählungen
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • n
  • o
  • r
  • s
  • t
Hier folgt die Aufzählung aller dokumentierten Namensbereichselemente mit Verweisen auf die zugehörigen Dateien:

- a -

  • ACLibErrorHandlerMode : modErrorHandler
  • ACLibErrorNumbers : modErrorHandler
  • ACLibErrorResumeMode : modErrorHandler
  • AddApplicationHandlerExtension() : modApplication
  • AddToZipFile() : modFiles
  • AdoCount() : modADO
  • AdoExecute() : modADO
  • AdoInsertIdentityReturn() : modADO
  • AdoInsertValuesIdentityReturn() : modADO
  • AdoLookup() : modADO
  • AdoLookupSQL() : modADO

- c -

  • CheckConnectionStatus() : modDbConnection
  • CreateDirectory() : modFiles
  • CurrentApplication() : modApplication
  • CurrentApplicationName() : defGlobal
  • CurrentConnection() : modADO
  • CurrentConnectionInfo() : modDbConnection
  • CurrentDbBE() : modODBC
  • CurrentDbC() : modDAO
  • CurrentDbConnection() : modDbConnection

- d -

  • DaoCount() : modDAO
  • DaoExecute() : modDAO
  • DaoInsertIdentityReturn() : modDAO
  • DaoLookupSQL() : modDAO
  • DateToSqlText() : SqlTools
  • DbmsConfigFormName() : defGlobal_DBMS
  • DbmsConnectionModes : defGlobal_DBMS
  • DefaultErrorHandlerMode() : modErrorHandler
  • DeleteOdbcTableDefs() : modODBC
  • DeleteTableDef() : modDAO
  • DirExists() : modFiles
  • DisposeCurrentApplicationHandler() : modApplication

- e -

  • ErrorHandlerLogFile() : modErrorHandler

- f -

  • FileExists() : modFiles
  • FileNameWithoutPath() : modFiles

- g -

  • GetClearedStringForFileName() : modFiles
  • GetControl() : modWinAPI_Handles
  • GetDetailSection() : modWinAPI_Handles
  • GetDirFromFilePath() : modFiles
  • GetFileUpdateDate() : modFiles
  • GetFooterSection() : modWinAPI_Handles
  • GetFullPathFromRelativPath() : modFiles
  • GetHeaderSection() : modWinAPI_Handles
  • GetMDI() : modWinAPI_Handles
  • GetPixelFromTwips() : modWinAPI_Layout
  • GetRelativPathFromFullPath() : modFiles
  • GetScrollbarWidth() : modWinAPI_Layout
  • GetSQLString_Date() : modSQL_Tools
  • GetSQLString_Number() : modSQL_Tools
  • GetSQLString_Text() : modSQL_Tools
  • GetTwipsFromPixel() : modWinAPI_Layout

- h -

  • HandleError() : modErrorHandler

- i -

  • InitConfig() : _config_Application

- l -

  • LaunchAppSynchronous() : modWinAPI
  • LinkTable() : modODBC

- n -

  • NumberToSqlText() : SqlTools

- o -

  • OdbcExecutePT() : modODBC
  • OpenAdoRecordset() : modADO
  • OpenDaoRecordset() : modDAO
  • OpenRecordsetDaoBE() : modODBC
  • OpenRecordsetPT() : modODBC

- r -

  • ReconnectODBC() : modODBC

- s -

  • SelectFile() : modFiles
  • SelectFolder() : modFiles
  • SetBackColor() : modWinAPI_Layout
  • SetFormIconFromFile() : modWinAPI
  • ShellExecuteOpenFile() : modWinAPI
  • ShellExecuteSendMail() : modWinAPI
  • ShortFileName() : modFiles
  • StartApplication() : _initApplication

- t -

  • TempPath() : modFiles
  • TextToSqlText() : SqlTools
  • TraceLog() : modApplication
  • TwipsPerPixelX() : modWinAPI_Layout
  • TwipsPerPixelY() : modWinAPI_Layout


DBMS Connection Wizard: Elementverzeichnis

  • Auflistung der Klassen
  • Klassen-Verzeichnis
  • Klassen-Elemente

AdodbHandler Elementverzeichnis

Vollständige Aufstellung aller Elemente für AdodbHandler einschließlich aller geerbten Elemente.
ConnectionString() As String | AdodbHandler
ConnectionString(ByVal Value As String) | AdodbHandler
Count(ByVal Expr As String, ByVal Domain As String, Optional ByVal Criteria As Variant) As Long | AdodbHandler
CurrentConnection() As ADODB.Connection | AdodbHandler
CurrentConnection(ByRef NewConnection As ADODB.Connection) | AdodbHandler
ErrorEmptyConnectionString(ByVal Msg As String, ByRef NewConnectionString As String) | AdodbHandler
ErrorMissingCurrentConnection(ByVal Msg As String, ByRef NewCurrentConnection As ADODB.Connection) | AdodbHandler
Execute(ByVal CommandText As String, Optional ByRef RecordsAffected As Long, Optional ByVal Options As ADODB.ExecuteOptionEnum=-1) As ADODB.Recordset | AdodbHandler
ExecuteCommand(ByVal CmdText As String, ByVal CmdType As ADODB.CommandTypeEnum, Optional ByVal CmdParamDefs As Variant, Optional ByRef RecordsAffected As Long, Optional ByVal Options As Long=-1) As ADODB.Recordset | AdodbHandler
InsertIdentityReturn(ByVal InsertSQL As String, Optional ByVal IdentityTable As String=vbNullString) As Variant | AdodbHandler
Lookup(ByVal Expr As String, ByVal Domain As String, Optional ByVal Criteria As Variant, Optional ByVal ValueIfNull As Variant=Null) As Variant | AdodbHandler
LookupSQL(ByVal SqlText As String, Optional ByVal Index As Variant=0 &, Optional ByVal ValueIfNull As Variant=Null) As Variant | AdodbHandler
Max(ByVal Expr As String, ByVal Domain As String, Optional ByVal Criteria As Variant) As Variant | AdodbHandler
Min(ByVal Expr As String, ByVal Domain As String, Optional ByVal Criteria As Variant) As Variant | AdodbHandler
OpenRecordset(ByVal Source As String, Optional ByVal CursorType As ADODB.CursorTypeEnum=ADODB.CursorTypeEnum.adOpenForwardOnly, Optional ByVal LockType As ADODB.LockTypeEnum=ADODB.LockTypeEnum.adLockReadOnly, Optional ByVal CursorLocation As ADODB.CursorLocationEnum=ADODB.CursorLocationEnum.adUseServer, Optional ByVal DisconnectedRecordset As Boolean=False) As ADODB.Recordset | AdodbHandler
Sum(ByVal Expr As String, ByVal Domain As String, Optional ByVal Criteria As Variant) As Variant | AdodbHandler


DBMS Connection Wizard: Elementverzeichnis

  • Auflistung der Klassen
  • Klassen-Verzeichnis
  • Klassen-Elemente

ApplicationHandler Elementverzeichnis

Vollständige Aufstellung aller Elemente für ApplicationHandler einschließlich aller geerbten Elemente.
AppDb() As DAO.Database | ApplicationHandler |
ApplicationFullName() As String | ApplicationHandler |
ApplicationFullName(ByVal AppName As String) | ApplicationHandler |
ApplicationName() As String | ApplicationHandler |
ApplicationName(ByVal AppName As String) | ApplicationHandler |
ApplicationStartFormName() As String | ApplicationHandler |
ApplicationStartFormName(ByVal FormName As String) | ApplicationHandler |
CallExtensionProcedure(ByVal Key As String, ByVal ProcedureName As String, ByRef ResumeMode As ApplicationHandlerResumeModes, ByRef ResumeMessage As Variant, ByRef params() As Variant) | ApplicationHandler |
CreateAppFile(ByVal sFileID As String, ByVal sFileName As String) As Boolean | ApplicationHandler |
GetExtensionInstance(ByVal ExtensionKey As String, Optional ByVal InstanceKey As String=vbNullString) As Object | ApplicationHandler |
MdiBackColor(ByVal Color As Long) | ApplicationHandler | [friend]
Start(Optional ByRef ResumeMessage As Variant) As Boolean | ApplicationHandler |
Version() As String | ApplicationHandler |
Version(ByVal appVersion As String) | ApplicationHandler |


DBMS Connection Wizard: Elementverzeichnis

  • Auflistung der Klassen
  • Klassen-Verzeichnis
  • Klassen-Elemente

DaoHandler Elementverzeichnis

Vollständige Aufstellung aller Elemente für DaoHandler einschließlich aller geerbten Elemente.
Count(ByVal Expr As String, ByVal Domain As String, Optional ByVal Criteria As Variant) As Long | DaoHandler
CurrentDb() As DAO.Database | DaoHandler
CurrentDb(ByRef NewCurrentDb As DAO.Database) | DaoHandler
ErrorMissingCurrentDb(ByVal Msg As String, ByRef NewCurrentDbRef As DAO.Database) | DaoHandler
Execute(ByVal Query As String, Optional ByVal Options As DAO.RecordsetOptionEnum) As Long | DaoHandler
ExecuteParamSQL(ByVal SqlText As String, ParamArray ParamValues() As Variant) As Long | DaoHandler
ExecuteQueryDef(ByVal qdf As DAO.QueryDef, Optional ByVal QdfParamDefs As Variant) As Long | DaoHandler
ExecuteQueryDefByName(ByVal QueryName As String, Optional ByVal QueryParamDefs As Variant) As Long | DaoHandler
InsertIdentityReturn(ByVal InsertSQL As String) As Variant | DaoHandler
Lookup(ByVal Expr As String, ByVal Domain As String, Optional ByVal Criteria As Variant, Optional ByVal ValueIfNull As Variant=Null) As Variant | DaoHandler
LookupSQL(ByVal SqlText As String, Optional ByVal Index As Variant=0 &, Optional ByVal ValueIfNull As Variant=Null) As Variant | DaoHandler
Max(ByVal Expr As String, ByVal Domain As String, Optional ByVal Criteria As Variant) As Variant | DaoHandler
Min(ByVal Expr As String, ByVal Domain As String, Optional ByVal Criteria As Variant) As Variant | DaoHandler
OpenRecordset(ByVal Source As String, Optional ByVal RecordsetType As DAO.RecordsetTypeEnum=dbOpenDynaset, Optional ByVal RecordsetOptions As DAO.RecordsetOptionEnum=DAO.RecordsetOptionEnum.dbSeeChanges, Optional ByVal LockEdit As DAO.LockTypeEnum=DAO.LockTypeEnum.dbOptimistic) As DAO.Recordset | DaoHandler
OpenRecordsetParamSQL(ByVal ParamSqlText As String, ByVal RecordsetType As DAO.RecordsetTypeEnum, ByVal Options As DAO.RecordsetOptionEnum, ByVal LockEdit As DAO.LockTypeEnum, ParamArray ParamValues() As Variant) As DAO.Recordset | DaoHandler
OpenRecordsetQueryDef(ByVal qdf As DAO.QueryDef, Optional ByVal QdfParamDefs As Variant, Optional ByVal RecordsetType As DAO.RecordsetTypeEnum, Optional ByVal Options As DAO.RecordsetOptionEnum, Optional ByVal LockEdit As DAO.LockTypeEnum) As DAO.Recordset | DaoHandler
OpenRecordsetQueryDefByName(ByVal QueryName As String, Optional ByVal QueryParamDefs As Variant, Optional ByVal RecordsetType As DAO.RecordsetTypeEnum, Optional ByVal Options As DAO.RecordsetOptionEnum, Optional ByVal LockEdit As DAO.LockTypeEnum) As DAO.Recordset | DaoHandler
Sum(ByVal Expr As String, ByVal Domain As String, Optional ByVal Criteria As Variant) As Variant | DaoHandler


DBMS Connection Wizard: Elementverzeichnis

  • Auflistung der Klassen
  • Klassen-Verzeichnis
  • Klassen-Elemente

DbConnectionHandler Elementverzeichnis

Vollständige Aufstellung aller Elemente für DbConnectionHandler einschließlich aller geerbten Elemente.
ADODB() As AdodbHandler | DbConnectionHandler
CurrentConnection() As ADODB.Connection | DbConnectionHandler
CurrentConnection(ByRef NewConnection As ADODB.Connection) | DbConnectionHandler
CurrentDb() As DAO.Database | DbConnectionHandler
CurrentDb(ByRef NewCurrentDb As DAO.Database) | DbConnectionHandler
CurrentDbBE() As DAO.Database | DbConnectionHandler
CurrentDbBE(ByRef NewCurrentDbBE As DAO.Database) | DbConnectionHandler
DAO() As DaoHandler | DbConnectionHandler
Dispose() | DbConnectionHandler
Disposed() | DbConnectionHandler
ErrorEmptyOdbcConnectionString(ByVal Msg As String, ByRef NewConnectionString As String) | DbConnectionHandler
ErrorEmptyOledbConnectionString(ByVal Msg As String, ByRef NewConnectionString As String) | DbConnectionHandler
ErrorMissingCurrentConnection(ByVal Msg As String, ByRef NewCurrentConnection As ADODB.Connection) | DbConnectionHandler
ErrorMissingCurrentDb(ByVal Msg As String, ByRef NewCurrentDbRef As DAO.Database) | DbConnectionHandler
ODBC() As OdbcHandler | DbConnectionHandler
OdbcConnectionString() As String | DbConnectionHandler
OdbcConnectionString(ByVal sConnectionString As String) | DbConnectionHandler
OledbConnectionString() As String | DbConnectionHandler
OledbConnectionString(ByVal sConnectionString As String) | DbConnectionHandler


DBMS Connection Wizard: Elementverzeichnis

  • Auflistung der Klassen
  • Klassen-Verzeichnis
  • Klassen-Elemente

DbConnectionInfo Elementverzeichnis

Vollständige Aufstellung aller Elemente für DbConnectionInfo einschließlich aller geerbten Elemente.
ChangeDbUserPassword(ByVal NewPassword As String, ByVal OldPassword As String, Optional ByVal LoginName As String=vbNullString, Optional ByRef Msg As String) As Boolean | DbConnectionInfo
CheckConnection(Optional ByRef ErrMsg As String=vbNullString) As Boolean | DbConnectionInfo
ClearConnectionInfo() | DbConnectionInfo
ConnectionStrings() As DbmsConnectionStrings | DbConnectionInfo
DbmsConnectionChanged(ByVal newCID As String) | DbConnectionInfo
DbmsConnectionInfoCleared() | DbConnectionInfo
DbmsInfoMessage(ByVal Source As String, ByVal Msg As String, ByVal MsgStyle As VbMsgBoxStyle) | DbConnectionInfo
DbUser(Optional ByVal withoutServerCheck As Boolean=False) As String | DbConnectionInfo
DbUserPassword() As String | DbConnectionInfo
OdbcConnectionString(Optional ByVal bWithoutUserInfo As Boolean=False) As String | DbConnectionInfo
OledbConnectionString() As String | DbConnectionInfo
ParseTableName(ByVal sTabName As String) As String | DbConnectionInfo
PermanentBackendRstSqlText() As String | DbConnectionInfo
SavePassword() As Boolean | DbConnectionInfo
TableListSqlText() As String | DbConnectionInfo
UseLoginForm() As Boolean | DbConnectionInfo


DBMS Connection Wizard: Elementverzeichnis

  • Auflistung der Klassen
  • Klassen-Verzeichnis
  • Klassen-Elemente

DbConnectionManager Elementverzeichnis

Vollständige Aufstellung aller Elemente für DbConnectionManager einschließlich aller geerbten Elemente.
CheckConnectionStatus() As Boolean | DbConnectionManager
ConnectionInfo() As DbConnectionInfo | DbConnectionManager
DbConnection() As DbConnectionHandler | DbConnectionManager


DBMS Connection Wizard: Elementverzeichnis

  • Auflistung der Klassen
  • Klassen-Verzeichnis
  • Klassen-Elemente

Form_frmConfig_DBMS Elementverzeichnis

Vollständige Aufstellung aller Elemente für Form_frmConfig_DBMS einschließlich aller geerbten Elemente.


DBMS Connection Wizard: Elementverzeichnis

  • Auflistung der Klassen
  • Klassen-Verzeichnis
  • Klassen-Elemente

OdbcHandler Elementverzeichnis

Vollständige Aufstellung aller Elemente für OdbcHandler einschließlich aller geerbten Elemente.
ConnectionString() As String | OdbcHandler
ConnectionString(ByVal Value As String) | OdbcHandler
Count(ByVal Expr As String, ByVal Domain As String, Optional ByVal Criteria As Variant) As Variant | OdbcHandler
CurrentDb() As DAO.Database | OdbcHandler
CurrentDb(ByRef NewCurrentDb As DAO.Database) | OdbcHandler
CurrentDbBE() As DAO.Database | OdbcHandler
CurrentDbBE(ByRef NewCurrentDbBE As DAO.Database) | OdbcHandler
DbObjectDeleted(ByVal LastDbObjectName As String, ByVal lCounter As Long) | OdbcHandler
DbObjectRelinked(ByVal LastDbObjectName As String, ByVal lCounter As Long) | OdbcHandler
DeleteOdbcTableDefs(Optional ByVal EventPeriod As Long=0) As Long | OdbcHandler
ErrorEmptyConnectionString(ByVal Msg As String, ByRef NewConnectionString As String) | OdbcHandler
ErrorMissingCurrentDb(ByVal Msg As String, ByRef NewCurrentDbRef As DAO.Database) | OdbcHandler
Execute(ByVal CommandText As String, Optional ByVal Options As DAO.RecordsetOptionEnum) As Long | OdbcHandler
ExecutePT(ByVal CommandText As String, Optional ByVal Options As DAO.RecordsetOptionEnum=DAO.RecordsetOptionEnum.dbSQLPassThrough) As Long | OdbcHandler
HookInsertIdentityReturn(ByRef InsertSQL As String, ByRef ActiveDb As DAO.Database, ByRef IdentitySelectString As String, ByRef ResponseMode As Long, ByRef ResponseMessage As Variant) | OdbcHandler
InsertIdentityReturn(ByVal InsertSQL As String) As Variant | OdbcHandler
LinkTable(ByVal SourceTableName As String, Optional ByVal LinkedTableName As String=vbNullString, Optional ByVal SavePWD As Boolean=False, Optional ByVal RemoveSchemaName As Boolean=True) | OdbcHandler
Lookup(ByVal Expr As String, ByVal Domain As String, Optional ByVal Criteria As Variant, Optional ByVal ValueIfNull As Variant=Null) As Variant | OdbcHandler
LookupSQL(ByVal SqlText As String, Optional ByVal Index As Variant=0 &, Optional ByVal ValueIfNull As Variant=Null) As Variant | OdbcHandler
LookupSqlPT(ByVal SqlText As String, Optional ByVal Index As Variant=0 &, Optional ByVal ValueIfNull As Variant=Null) As Variant | OdbcHandler
Max(ByVal Expr As String, ByVal Domain As String, Optional ByVal Criteria As Variant) As Variant | OdbcHandler
Min(ByVal Expr As String, ByVal Domain As String, Optional ByVal Criteria As Variant) As Variant | OdbcHandler
OpenRecordset(ByVal Source As String, Optional ByVal RecordsetType As DAO.RecordsetTypeEnum=dbOpenForwardOnly, Optional ByVal RecordsetOptions As DAO.RecordsetOptionEnum=DAO.RecordsetOptionEnum.dbSeeChanges, Optional ByVal LockEdit As DAO.LockTypeEnum=DAO.LockTypeEnum.dbOptimistic) As DAO.Recordset | OdbcHandler
OpenRecordsetPT(ByVal Source As String, Optional ByVal RecordsetType As DAO.RecordsetTypeEnum=dbOpenForwardOnly, Optional ByVal RecordsetOptions As DAO.RecordsetOptionEnum=DAO.RecordsetOptionEnum.dbSeeChanges Or DAO.RecordsetOptionEnum.dbSQLPassThrough, Optional ByVal LockEdit As DAO.LockTypeEnum=DAO.LockTypeEnum.dbOptimistic) As DAO.Recordset | OdbcHandler
RelinkPassThroughQueries(Optional ByVal SavePWD As Boolean=False, Optional ByVal EventPeriod As Long=0) As Long | OdbcHandler
RelinkPassThroughQuery(ByVal QueryName As String, Optional ByVal SavePWD As Boolean=False) As Boolean | OdbcHandler
RelinkTable(ByVal LinkedTableName As String, Optional ByVal SavePWD As Boolean=False) As Boolean | OdbcHandler
RelinkTables(Optional ByVal SavePWD As Boolean=False, Optional ByVal EventPeriod As Long=0) As Long | OdbcHandler
RelinkTablesAndQueries(Optional ByVal SavePWD As Boolean=False, Optional ByVal EventPeriod As Long=0) As Long | OdbcHandler
Sum(ByVal Expr As String, ByVal Domain As String, Optional ByVal Criteria As Variant) As Variant | OdbcHandler


DBMS Connection Wizard: Elementverzeichnis

  • Auflistung der Klassen
  • Klassen-Verzeichnis
  • Klassen-Elemente

WinApiShortcutMenu Elementverzeichnis

Vollständige Aufstellung aller Elemente für WinApiShortcutMenu einschließlich aller geerbten Elemente.
AddMenuItem(ByVal lMenuItemNumber As Long, ByVal sItemText As String, Optional ByVal lItemType As MenuItemStyle=MF_STRING, Optional ByVal lSubMenu As Long=0, Optional ByVal bDefaultItem As Boolean=False) | WinApiShortcutMenu
OpenMenu(Optional ByVal x As Single=0, Optional ByVal y As Single=0) As Long | WinApiShortcutMenu


DBMS Connection Wizard: Klassen-Elemente - Funktionen

  • Auflistung der Klassen
  • Klassen-Verzeichnis
  • Klassen-Elemente
  • Alle
  • Funktionen
  • Verwandte Funktionen
  • a
  • c
  • d
  • e
  • g
  • h
  • i
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v

- a -

  • AddMenuItem() : WinApiShortcutMenu
  • ADODB() : DbConnectionHandler
  • AppDb() : ApplicationHandler
  • ApplicationFullName() : ApplicationHandler
  • ApplicationName() : ApplicationHandler
  • ApplicationStartFormName() : ApplicationHandler

- c -

  • CallExtensionProcedure() : ApplicationHandler
  • ChangeDbUserPassword() : DbConnectionInfo
  • CheckConnection() : DbConnectionInfo
  • CheckConnectionStatus() : DbConnectionManager
  • ClearConnectionInfo() : DbConnectionInfo
  • ConnectionInfo() : DbConnectionManager
  • ConnectionString() : AdodbHandler , OdbcHandler , AdodbHandler
  • ConnectionStrings() : DbConnectionInfo
  • Count() : AdodbHandler , DaoHandler , OdbcHandler
  • CreateAppFile() : ApplicationHandler
  • CurrentConnection() : AdodbHandler , DbConnectionHandler
  • CurrentDb() : DbConnectionHandler , DaoHandler , DbConnectionHandler , OdbcHandler
  • CurrentDbBE() : DbConnectionHandler , OdbcHandler , DbConnectionHandler

- d -

  • DAO() : DbConnectionHandler
  • DbConnection() : DbConnectionManager
  • DbmsConnectionChanged() : DbConnectionInfo
  • DbmsConnectionInfoCleared() : DbConnectionInfo
  • DbmsInfoMessage() : DbConnectionInfo
  • DbObjectDeleted() : OdbcHandler
  • DbObjectRelinked() : OdbcHandler
  • DbUser() : DbConnectionInfo
  • DbUserPassword() : DbConnectionInfo
  • DeleteOdbcTableDefs() : OdbcHandler
  • Dispose() : DbConnectionHandler
  • Disposed() : DbConnectionHandler

- e -

  • ErrorEmptyConnectionString() : AdodbHandler , OdbcHandler
  • ErrorEmptyOdbcConnectionString() : DbConnectionHandler
  • ErrorEmptyOledbConnectionString() : DbConnectionHandler
  • ErrorMissingCurrentConnection() : AdodbHandler , DbConnectionHandler
  • ErrorMissingCurrentDb() : DbConnectionHandler , OdbcHandler , DaoHandler
  • Execute() : DaoHandler , AdodbHandler , OdbcHandler
  • ExecuteCommand() : AdodbHandler
  • ExecuteParamSQL() : DaoHandler
  • ExecutePT() : OdbcHandler
  • ExecuteQueryDef() : DaoHandler
  • ExecuteQueryDefByName() : DaoHandler

- g -

  • GetExtensionInstance() : ApplicationHandler

- h -

  • HookInsertIdentityReturn() : OdbcHandler

- i -

  • InsertIdentityReturn() : AdodbHandler , OdbcHandler , DaoHandler

- l -

  • LinkTable() : OdbcHandler
  • Lookup() : AdodbHandler , OdbcHandler , DaoHandler
  • LookupSQL() : AdodbHandler , OdbcHandler , DaoHandler
  • LookupSqlPT() : OdbcHandler

- m -

  • Max() : AdodbHandler , DaoHandler , OdbcHandler
  • Min() : AdodbHandler , DaoHandler , OdbcHandler

- o -

  • ODBC() : DbConnectionHandler
  • OdbcConnectionString() : DbConnectionHandler , DbConnectionInfo , DbConnectionHandler
  • OledbConnectionString() : DbConnectionHandler , DbConnectionInfo
  • OpenMenu() : WinApiShortcutMenu
  • OpenRecordset() : AdodbHandler , DaoHandler , OdbcHandler
  • OpenRecordsetParamSQL() : DaoHandler
  • OpenRecordsetPT() : OdbcHandler
  • OpenRecordsetQueryDef() : DaoHandler
  • OpenRecordsetQueryDefByName() : DaoHandler

- p -

  • ParseTableName() : DbConnectionInfo
  • PermanentBackendRstSqlText() : DbConnectionInfo

- r -

  • RelinkPassThroughQueries() : OdbcHandler
  • RelinkPassThroughQuery() : OdbcHandler
  • RelinkTable() : OdbcHandler
  • RelinkTables() : OdbcHandler
  • RelinkTablesAndQueries() : OdbcHandler

- s -

  • SavePassword() : DbConnectionInfo
  • Start() : ApplicationHandler
  • Sum() : DaoHandler , AdodbHandler , OdbcHandler

- t -

  • TableListSqlText() : DbConnectionInfo

- u -

  • UseLoginForm() : DbConnectionInfo

- v -

  • Version() : ApplicationHandler


DBMS Connection Wizard: Klassen-Elemente - Verwandte Funktionen

  • Auflistung der Klassen
  • Klassen-Verzeichnis
  • Klassen-Elemente
  • Alle
  • Funktionen
  • Verwandte Funktionen
  • MdiBackColor : ApplicationHandler


DBMS Connection Wizard: Erklärung des Graphen

Erklärung des Graphen

Diese Seite erklärt die Interpretation der von doxygen erzeugten Graphen.

Beispiel:

/*! Wegen Verkürzung unsichtbare Klasse */
class Invisible { };

/*! Klasse verkürzt dargestellt, Vererbungsbeziehung ist versteckt */
class Truncated : public Invisible { };

/* Nicht mit doxygen-Kommentaren dokumentierte Klasse */
class Undocumented { };

/*! Mithilfe öffentlicher Vererbung vererbte Klasse */
class PublicBase : public Truncated { };

/*! Eine Template-Klasse */
template<class T> class Templ { };

/*! Mithilfe geschützter Vererbung vererbte Klasse */
class ProtectedBase { };

/*! Mithilfe privater Vererbung vererbte Klasse */
class PrivateBase { };

/*! Von der Klasse Inherited benutzte Klasse */
class Used { };

/*! Superklasse, die von mehreren anderen Klassen erbt */
class Inherited : public PublicBase,
                  protected ProtectedBase,
                  private PrivateBase,
                  public Undocumented,
                  public Templ<int>
{
  private:
    Used *m_usedClass;
};

Dies liefert den folgenden Graphen:

Die Rechtecke in obigem Graphen bedeuten:

  • Ein grau gefülltes Rechteck stellt die Struktur oder Klasse dar, für die der Graph erzeugt wurde.
  • Ein Rechteck mit schwarzem Rahmen kennzeichnet eine dokumentierte Struktur oder Klasse.
  • Ein Rechteck mit grauem Rahmen kennzeichnet eine undokumentierte Struktur oder Klasse.
  • Ein Rechteck mit rotem Rahmen kennzeichnet eine dokumentierte Struktur oder Klasse, für die nicht alle Vererbungs-/Enthaltenseinsbeziehungen dargestellt werden. Ein Graph wird gekürzt, wenn er nicht in die angegebenen Schranken passt.

Die Pfeile bedeuten:

  • Ein dunkelblauer Pfeil stellt eine öffentliche Vererbungsbeziehung zwischen zwei Klassen dar.
  • Ein dunkelgrüner Pfeil stellt geschützte Vererbung dar.
  • Ein dunkelroter Pfeil stellt private Vererbung dar.
  • Ein gestrichelter violetter Pfeil bedeutet, dass eine Klasse in einer anderen enthalten ist oder von einer anderen benutzt wird. Am Pfeil stehen die Variable(n), mit deren Hilfe auf die Struktur oder Klasse an der Pfeilspitze zugegriffen werden kann.
  • Ein gestrichelter gelber Pfeil kennzeichnet eine Verknüpfung zwischen einer Template Instanz und der Template Klasse von welcher es abstammt. Neben dem Pfeil sind die Template Parameter aufgeführt.


DBMS Connection Wizard: Paketfunktionen

  • Pakete
  • Paketfunktionen
  • Alle
  • Funktionen
  • Aufzählungen
  • ACLibErrorHandlerMode : modErrorHandler
  • ACLibErrorNumbers : modErrorHandler
  • ACLibErrorResumeMode : modErrorHandler
  • DbmsConnectionModes : defGlobal_DBMS


DBMS Connection Wizard: Paketfunktionen

  • Pakete
  • Paketfunktionen
  • Alle
  • Funktionen
  • Aufzählungen
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • n
  • o
  • r
  • s
  • t

- a -

  • AddApplicationHandlerExtension() : modApplication
  • AddToZipFile() : modFiles
  • AdoCount() : modADO
  • AdoExecute() : modADO
  • AdoInsertIdentityReturn() : modADO
  • AdoInsertValuesIdentityReturn() : modADO
  • AdoLookup() : modADO
  • AdoLookupSQL() : modADO

- c -

  • CheckConnectionStatus() : modDbConnection
  • CreateDirectory() : modFiles
  • CurrentApplication() : modApplication
  • CurrentApplicationName() : defGlobal
  • CurrentConnection() : modADO
  • CurrentConnectionInfo() : modDbConnection
  • CurrentDbBE() : modODBC
  • CurrentDbC() : modDAO
  • CurrentDbConnection() : modDbConnection

- d -

  • DaoCount() : modDAO
  • DaoExecute() : modDAO
  • DaoInsertIdentityReturn() : modDAO
  • DaoLookupSQL() : modDAO
  • DateToSqlText() : SqlTools
  • DbmsConfigFormName() : defGlobal_DBMS
  • DefaultErrorHandlerMode() : modErrorHandler
  • DeleteOdbcTableDefs() : modODBC
  • DeleteTableDef() : modDAO
  • DirExists() : modFiles
  • DisposeCurrentApplicationHandler() : modApplication

- e -

  • ErrorHandlerLogFile() : modErrorHandler

- f -

  • FileExists() : modFiles
  • FileNameWithoutPath() : modFiles

- g -

  • GetClearedStringForFileName() : modFiles
  • GetControl() : modWinAPI_Handles
  • GetDetailSection() : modWinAPI_Handles
  • GetDirFromFilePath() : modFiles
  • GetFileUpdateDate() : modFiles
  • GetFooterSection() : modWinAPI_Handles
  • GetFullPathFromRelativPath() : modFiles
  • GetHeaderSection() : modWinAPI_Handles
  • GetMDI() : modWinAPI_Handles
  • GetPixelFromTwips() : modWinAPI_Layout
  • GetRelativPathFromFullPath() : modFiles
  • GetScrollbarWidth() : modWinAPI_Layout
  • GetSQLString_Date() : modSQL_Tools
  • GetSQLString_Number() : modSQL_Tools
  • GetSQLString_Text() : modSQL_Tools
  • GetTwipsFromPixel() : modWinAPI_Layout

- h -

  • HandleError() : modErrorHandler

- i -

  • InitConfig() : _config_Application

- l -

  • LaunchAppSynchronous() : modWinAPI
  • LinkTable() : modODBC

- n -

  • NumberToSqlText() : SqlTools

- o -

  • OdbcExecutePT() : modODBC
  • OpenAdoRecordset() : modADO
  • OpenDaoRecordset() : modDAO
  • OpenRecordsetDaoBE() : modODBC
  • OpenRecordsetPT() : modODBC

- r -

  • ReconnectODBC() : modODBC

- s -

  • SelectFile() : modFiles
  • SelectFolder() : modFiles
  • SetBackColor() : modWinAPI_Layout
  • SetFormIconFromFile() : modWinAPI
  • ShellExecuteOpenFile() : modWinAPI
  • ShellExecuteSendMail() : modWinAPI
  • ShortFileName() : modFiles
  • StartApplication() : _initApplication

- t -

  • TempPath() : modFiles
  • TextToSqlText() : SqlTools
  • TraceLog() : modApplication
  • TwipsPerPixelX() : modWinAPI_Layout
  • TwipsPerPixelY() : modWinAPI_Layout


DBMS Connection Wizard: Elementverzeichnis

  • Auflistung der Klassen
  • Klassen-Verzeichnis
  • Klassen-Elemente
  • defGlobal_DBMS
  • DbmsConnectionStrings

DbmsConnectionStrings Elementverzeichnis

Vollständige Aufstellung aller Elemente für DbmsConnectionStrings einschließlich aller geerbten Elemente.